Bug #83123 Replicating from mariadb 10.0.20 master crashed the mysql 5.6.21 slave
Submitted: 23 Sep 2016 8:22 Modified: 23 Sep 2016 10:38
Reporter: Guangpu Feng Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Replication Severity:S2 (Serious)
Version:5.6.21 OS:CentOS
Assigned to: CPU Architecture:Any
Tags: crash, MariaDB, replication

[23 Sep 2016 8:22] Guangpu Feng
Description:
MariaDB 10.0.20 is the master, after I set up a mysql 5.6.21 slave, it crashed when executing 'start slave', here is the error log:

2016-09-23 16:08:14 23271 [Warning] Storing MySQL user name or password information in the master info repository is not secure and is therefore not recommended. Please consider using the USER and PASSWORD connection options for START SLAVE; see the 'START SLAVE Syntax' in the MySQL Manual for more information.
2016-09-23 16:08:14 23271 [Note] Slave I/O thread: connected to master 'wolf@10.248.6.17:3306',replication started in log 'mysqld-bin.003742' at position 105384195
2016-09-23 16:08:14 23271 [Warning] Slave SQL: If a crash happens this configuration does not guarantee that the relay log info will be consistent, Error_code: 0
2016-09-23 16:08:14 23271 [Note] Slave SQL thread initialized, starting replication in log 'mysqld-bin.003742' at position 616115, relay log './relay-bin.000002' position: 4264
2016-09-23 16:08:14 23271 [Warning] Slave I/O: Unknown system variable 'SERVER_UUID' on master. A probable cause is that the variable is not supported on the master (version: 5.5.5-10.0.20-MariaDB-log), even though it is on the slave (version: 5.6.21-log), Error_code: 1193
08:08:14 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

key_buffer_size=8388608
read_buffer_size=8388608
max_used_connections=2
max_threads=1000
thread_count=4
connection_count=2
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 16405871 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x7fb674000990
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7fb6994d9d10 thread_stack 0x30000
/usr/local/mysql-5.6.21/bin/mysqld(my_print_stacktrace+0x2e)[0x9dff7e]
/usr/local/mysql-5.6.21/bin/mysqld(handle_fatal_signal+0x3b0)[0x6fc09c]
/lib64/libpthread.so.0[0x36c2e0f710]
/usr/local/mysql-5.6.21/bin/mysqld(_ZN5Field12unpack_int64EPhPKhb+0x25)[0x8a60c7]
/usr/local/mysql-5.6.21/bin/mysqld(_ZN14Field_datetime6unpackEPhPKhjb+0x39)[0x8a8a19]
/usr/local/mysql-5.6.21/bin/mysqld(_Z10unpack_rowPK14Relay_log_infoP5TABLEjPKhPK9st_bitmapPS5_PmS5_+0x387)[0x99a2c5]
/usr/local/mysql-5.6.21/bin/mysqld(_ZN14Rows_log_event18unpack_current_rowEPK14Relay_log_infoPK9st_bitmap+0x9a)[0x97f9bc]
/usr/local/mysql-5.6.21/bin/mysqld(_ZN20Write_rows_log_event9write_rowEPK14Relay_log_infob+0x8f)[0x97b989]
/usr/local/mysql-5.6.21/bin/mysqld(_ZN20Write_rows_log_event11do_exec_rowEPK14Relay_log_info+0x35)[0x97c039]
/usr/local/mysql-5.6.21/bin/mysqld(_ZN14Rows_log_event12do_apply_rowEPK14Relay_log_info+0x75)[0x9775d3]
/usr/local/mysql-5.6.21/bin/mysqld(_ZN14Rows_log_event14do_apply_eventEPK14Relay_log_info+0x9d5)[0x979431]
/usr/local/mysql-5.6.21/bin/mysqld(_ZN9Log_event11apply_eventEP14Relay_log_info+0x23a)[0x9698da]
/usr/local/mysql-5.6.21/bin/mysqld(_Z26apply_event_and_update_posPP9Log_eventP3THDP14Relay_log_info+0x1b9)[0x9abef0]
/usr/local/mysql-5.6.21/bin/mysqld[0x9acbda]
/usr/local/mysql-5.6.21/bin/mysqld(handle_slave_sql+0x75b)[0x9b08d4]
/usr/local/mysql-5.6.21/bin/mysqld(pfs_spawn_thread+0x156)[0xa6d12d]
/lib64/libpthread.so.0[0x36c2e079d1]
/lib64/libc.so.6(clone+0x6d)[0x3f7e8e8b6d]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (0): is an invalid pointer
Connection ID (thread ID): 4
Status: NOT_KILLED

The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
set up mysql 5.6.21 as the slave of mariadb 10.0.20

Suggested fix:
No ideal, mariadb 10.0 is drop-in replacement of mysql 5.6, but they are incompatible in replication.
[23 Sep 2016 9:47] Guangpu Feng
correct mysql slave version to 5.6.21 in title
[23 Sep 2016 10:38] Umesh Shastry
Hello Guangpu,

Thank you for the report.
Please note that 5.6.21 is very old and many bugs fixed since then. I suggest you to try latest 5.6 build and report us back if you are still seeing the crash with unaltered error log, conf files used etc.

If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Umesh