Bug #83008 MySQL X plugin - improve reporting if port in use
Submitted: 15 Sep 2016 8:38 Modified: 24 Jan 2017 14:36
Reporter: Simon Mudd (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Document Store: X Plugin Severity:S3 (Non-critical)
Version:8.0.0 OS:Any
Assigned to: CPU Architecture:Any

[15 Sep 2016 8:38] Simon Mudd
Description:
not checked 5.7 but may be similarly affected.

On starting up 2 instances with the X plugin configured on the same port 8.0.0 reports:

2016-09-15T07:43:17.562199Z 0 [ERROR] Plugin mysqlx reported: 'X Plugin failed to setup TCP (port:33060), with:'
2016-09-15T07:43:17.562205Z 0 [ERROR] Plugin mysqlx reported: 'could not bind to port 33060: Address already in use (48)'

How to repeat:
start to mysql instances with the X plugin installed and notice on the second one the error message.

Suggested fix:
The output is split over 2 lines rather than being on a single line which provides full context.
So should be of the form:

2016-09-15T07:43:17.562199Z 0 [ERROR] Plugin mysqlx reported: 'X Plugin failed to setup TCP (port:33060): could not bind to port 33060: Address already in use (48)'

Port 3306 seems redundant here. Depending on how you're doing this removing one of the entries though I think one of the messages is from the OS.
[15 Sep 2016 8:42] Daniƫl van Eeden
Might be a duplicate of:
Bug #81826 	X Plugin startup error messages

Related:
Bug #82761 	If binding to mysqlx port fails this is not visible from status vars
[16 Sep 2016 9:23] Umesh Shastry
Hello Simon,

Thank you for the report and feedback.
Verifying based on my internal discussion with the Developer.
I too initially thought it is dup of Bug#81826, but we concluded that this popped up after Bug #81826 fixed.

Thanks,
Umesh
[24 Jan 2017 14:36] Tony Bedford
Posted by developer:
 
An entry has been added to the 5.7.17 and 8.0.1 changelogs:

When two X Plugin instances were started on the same port, the resulting error message was split over two lines and                                                          contained duplicate information.