Bug #82802 page_cleaner reports consistent 40 second timeouts on server with no usage
Submitted: 30 Aug 2016 16:51 Modified: 31 Aug 2016 7:24
Reporter: Cody Lerum Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:5.7.14 OS:Ubuntu (16.04)
Assigned to: CPU Architecture:Any

[30 Aug 2016 16:51] Cody Lerum
Description:
On a MySQL slave that is on a VMware cluster talking using a Netapp SAN for storage I'm receiving the following logs constantly.

The server has almost no traffic as you can see from the flushed and evicted counts and CPU/IO are basically zero.

2016-08-30T16:40:19.790965Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 33997ms. The settings might not be optimal. (flushed=0 and evicted=0, during the time.)
2016-08-30T16:41:19.792951Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 33998ms. The settings might not be optimal. (flushed=0 and evicted=0, during the time.)
2016-08-30T16:42:19.793459Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 33997ms. The settings might not be optimal. (flushed=0 and evicted=0, during the time.)
2016-08-30T16:43:19.795862Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 34000ms. The settings might not be optimal. (flushed=33 and evicted=0, during the time.)
2016-08-30T16:44:19.796439Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 33999ms. The settings might not be optimal. (flushed=0 and evicted=0, during the time.)
2016-08-30T16:45:19.797950Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 33998ms. The settings might not be optimal. (flushed=0 and evicted=0, during the time.)
2016-08-30T16:46:19.799528Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 33999ms. The settings might not be optimal. (flushed=0 and evicted=0, during the time.)
2016-08-30T16:47:19.800654Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 33999ms. The settings might not be optimal. (flushed=13 and evicted=0, during the time.)
2016-08-30T16:48:19.802025Z 0 [Note] InnoDB: page_cleaner: 1000ms intended loop took 33997ms. The settings might not be optimal. (flushed=0 and evicted=0, during the time.)

How to repeat:
Slave, Vmware, SAN storage

innodb settings: 

innodb_data_file_path = ibdata1:128M;ibdata2:10M:autoextend
innodb_file_per_table
innodb_buffer_pool_size = 4G
innodb_log_file_size = 512M
innodb_log_buffer_size = 128M
[31 Aug 2016 7:24] Umesh Shastry
Hello Cody Lerum,

Thank you for the report.
This is duplicate of Bug #76661, please see Bug #76661

Thanks,
Umesh