Bug #82741 Validation check not working correctly
Submitted: 26 Aug 2016 10:07 Modified: 9 Feb 2018 22:42
Reporter: Jonathan van der Ceelen Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S5 (Performance)
Version:6.3.7 OS:Linux (Ubuntu 16.04.1 LTS)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[26 Aug 2016 10:07] Jonathan van der Ceelen
Description:
----[For better reports, please attach the log file after submitting. You can find it in /home/jonathan/.mysql/workbench/log/wb.log]

Even for valid queries the validation check shows a red cross in front of the query.

How to repeat:
Write a query, make sure it is at one point invalid, than make it valid. The cross (invalied query, or 'there is a syntax error in your query' symbol) doesn't disappear.
[26 Aug 2016 10:10] Jonathan van der Ceelen
Error log

Attachment: error.log (text/x-log), 50.47 KiB.

[26 Aug 2016 10:31] Miguel Solorzano
Thank you for the bug report. Verified as described on Windows.
[27 Aug 2016 1:12] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=82748 marked as duplicate of this one.
[21 Sep 2016 22:54] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83086 marked as duplicate of this one.
[8 Feb 2017 19:26] Joel Anderson
Continues to happen for me on Workbench 6.3.8 Build 1228 CE 64-bit.
[14 Feb 2017 18:59] Tarek Faham
Same bug occurs on Workbench 6.3.7 (Windows 7 64 bits)

Tarek
[9 Feb 2018 22:42] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.0 release, and here's the changelog entry:

The invalid syntax indicator that appears on each line of the SQL Editor
did not change after the syntax was corrected or completed. This fix
ensures that the editor re-evaluates each change.

Thank you for the bug report.