Bug #82586 Installer for Windows hangs when creating ManifestUpdate Task
Submitted: 15 Aug 2016 19:31 Modified: 16 Aug 2016 22:54
Reporter: Irvin Lustig Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:1.4.17.0 OS:Microsoft Windows (Windows 10 Pro V1511 Build 10586.545)
Assigned to: Javier Rivera Zavala CPU Architecture:Any

[15 Aug 2016 19:31] Irvin Lustig
Description:
After I upgraded to Windows 10, the task ManifestUpdate was messed up in the TaskScheduler.  The directory C:\WINDOWS\System32\Tasks\MySQL\Installer existed, but was empty.  The installer shells out to "schtasks.exe" /CREATE /TN \MySQL\Installer\ManifestUpdate /SC DAILY /ST 00:00 /TR "'c:\program files (x86)\mysql\mysql installer for windows\mysqlinstallerconsole.exe' Community Update" and was hung in "schtasks".

So I opened up a CMD prompt with Administrator privileges, and ran that command.  I first got a warning with a prompt:

WARNING: The task name "\MySQL\Installer\ManifestUpdate" already exists. Do you want to replace it (Y/N)?

I replied "Y", and then got the message:
ERROR: Cannot create a file when that file already exists.

So then I deleted the folders C:\WINDOWS\System32\Tasks\MySQL\Installer and C:\WINDOWS\System32\Tasks\MySQL\  .  Ran the command from the command line, and it created the task.  The message was:

SUCCESS: The scheduled task "\MySQL\Installer\ManifestUpdate" has successfully been created.

So I think some care has to be taken when creating that task to make sure that the command doesn't fail, or get hung waiting for the prompt about the task already existing.

How to repeat:
If the directory C:\WINDOWS\System32\Tasks\MySQL\Installer is empty, I think the Windows installer will fail if you ask it to create the task.  By "fail", it will just hang.
[16 Aug 2016 22:54] Javier Rivera Zavala
I've been unable to reproduce the bug described above.

The severity will be lowered from 2 to 3 since the task creation for the automatic upgrade is not vital for the installer to work, plus the issue has a workaround and as of described above, deleting the scheduled task folder is very easy to do.

My suggestion will be to use the GUI installer to handle the schedule task creation in a way more friendly manner rather than trying to do this the hard way on the command line.
[24 Sep 2017 22:44] Sor Pos
I am trying to install mysql-installer-community-5.7.19.0.msi by running the GUI installer on Windows 10, and the installer hangs.

By looking in the log created by the command msiexec /i mysql-installer-community-5.7.19.0.msi /l*v mysql-installer-log.txt, this is what I see at the end of the log file:

MSI (s) (38:60) [23:55:33:154]: Executing op: ActionStart(Name=CreateTask,,)
MSI (s) (38:60) [23:55:33:185]: Executing op: CustomActionSchedule(Action=CreateTask,ActionType=1089,Source=BinaryData,Target=CreateTask,CustomActionData=\"C:\Program Files (x86)\MySQL\MySQL Installer for Windows\MySQLInstallerConsole.exe\" Community Update)
MSI (s) (38:64) [23:55:33:276]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSID37C.tmp, Entrypoint: CreateTask
MSI (s) (38:68) [23:55:33:280]: Generating random cookie.
MSI (s) (38:68) [23:55:33:280]: Created Custom Action Server with PID 12140 (0x2F6C).
MSI (s) (38:90) [23:55:33:410]: Running as a service.
MSI (s) (38:90) [23:55:33:410]: Hello, I'm your 32bit Impersonated custom action server.
SFXCA: Extracting custom action to temporary directory: C:\Users\myuser\AppData\Local\Temp\MSID37C.tmp-\
SFXCA: Binding to CLR version v4.0.30319
Calling custom action MySQLCA!MySQLCA.CustomActions.CreateTask
Creating scheduled task if doesn't already exist.

So it seems the installer hangs while trying to create scheduled task.
(Note that I have already deleted c:\Windows\System32\Tasks\MySQL\Installer before running the installer - as suggested by Irvin.)
[26 Feb 15:29] Gianluigi Salvi
I have the same issue