Bug #82389 sed: -e expression #1, char 17: unknown option to `s'
Submitted: 30 Jul 2016 15:10 Modified: 21 Sep 2016 17:05
Reporter: Peter VARGA Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.7.14 OS:SUSE (SLES 12 SP1)
Assigned to: CPU Architecture:Any
Tags: rpm, sed, UPDATE

[30 Jul 2016 15:10] Peter VARGA
Description:
Running the rpm file in order to update from 5.7.13 to 5.7.14 this error message is displayed:

sed: -e expression #1, char 17: unknown option to `s'

That far everything works but I noticed that immediately after the update the system disk had 712MB less space so I suspect it may happen while the cleaning up process.

Where are the files located which should have been cleaned up so I can check if this may be the problem.

How to repeat:
rpm -Uhv mysql-community-server-5.7.14-1.sles12.x86_64.rpm
[30 Jul 2016 20:09] Miguel Solorzano
Thank you for the bug report. After a backup of data directory and using MySQL SUSE repository I was able to upgrade without problem on OpenSUSE-Leap-42.1:

miguel@tikal:~> sudo mysqld --version
root's password:
mysqld  Ver 5.7.13 for Linux on x86_64 (MySQL Community Server (GPL))
miguel@tikal:~> sudo zypper repos | grep mysql.*community
 8 | mysql-connectors-community        | MySQL Connectors Community              | Yes     | (r ) Yes  | No     
 9 | mysql-connectors-community-source | MySQL Connectors Community - Source     | No      | ----      | No     
10 | mysql-tools-community             | MySQL Tools Community                   | Yes     | (r ) Yes  | No     
11 | mysql-tools-community-source      | MySQL Tools Community - Source          | No      | ----      | No     
12 | mysql56-community                 | MySQL 5.6 Community Server              | No      | ----      | No     
13 | mysql56-community-source          | MySQL 5.6 Community Server - Source     | No      | ----      | No     
14 | mysql57-community                 | MySQL 5.7 Community Server              | Yes     | (r ) Yes  | No     
15 | mysql57-community-source          | MySQL 5.7 Community Server - Source     | No      | ----      | No     
miguel@tikal:~> sudo zypper refresh
Repository 'nVidia Graphics Drivers' is up to date.                                                                      
<cut>                                                                  
Repository 'MySQL Connectors Community' is up to date.                                                                   
Repository 'MySQL Tools Community' is up to date.                                                                        
Retrieving repository 'MySQL 5.7 Community Server' metadata .......................................................[done]
Building repository 'MySQL 5.7 Community Server' cache ............................................................[done]
Repository 'openSUSE-42.1-0' is up to date.                                                                              
Repository 'packman' is up to date.                                                                                      
Repository 'openSUSE-Leap-42.1-Update' is up to date.                                                                    
All repositories have been refreshed.
miguel@tikal:~> sudo zypper install mysql-community-server
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 2 packages are going to be upgraded:
  mysql-community-common mysql-community-server

2 packages to upgrade.
Overall download size: 127.0 MiB. Already cached: 0 B. After the operation, additional 2.1 MiB will be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package mysql-community-common-5.7.14-1.sles12.x86_64                    (1/2), 227.1 KiB (  2.5 MiB unpacked)
Retrieving: mysql-community-common-5.7.14-1.sles12.x86_64.rpm .....................................................[done]
Retrieving package mysql-community-server-5.7.14-1.sles12.x86_64                    (2/2), 126.7 MiB (689.0 MiB unpacked)
Retrieving: mysql-community-server-5.7.14-1.sles12.x86_64.rpm .........................................[done (1.2 MiB/s)]
Checking for file conflicts: ......................................................................................[done]
(1/2) Installing: mysql-community-common-5.7.14-1.sles12.x86_64 ...................................................[done]
(2/2) Installing: mysql-community-server-5.7.14-1.sles12.x86_64 ...................................................[done]
There are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps -s' to list these programs.
miguel@tikal:~> sudo mysqld --version
mysqld  Ver 5.7.14 for Linux on x86_64 (MySQL Community Server (GPL))
[31 Jul 2016 7:41] Peter VARGA
I followed the steps as you updated your system and this worked without any problem.

But as I wrote in the opening comment I did not use zypper, I ran the rpm -Uhv command for all of these files individually:

mysql-5.7.14-1.sles12.x86_64.rpm-bundle.tar   <-- the downloaded file
mysql-community-client-5.7.14-1.sles12.x86_64.rpm
mysql-community-common-5.7.14-1.sles12.x86_64.rpm
mysql-community-devel-5.7.14-1.sles12.x86_64.rpm
mysql-community-embedded-5.7.14-1.sles12.x86_64.rpm
mysql-community-embedded-devel-5.7.14-1.sles12.x86_64.rpm
mysql-community-libs-5.7.14-1.sles12.x86_64.rpm
mysql-community-server-5.7.14-1.sles12.x86_64.rpm
mysql-community-test-5.7.14-1.sles12.x86_64.rpm
[7 Sep 2016 11:39] Terje Røsten
Hi Peter!

Thanks for reporting!

We have found the root cause and this will be fixed in upcoming release.
[21 Sep 2016 17:05] Paul Dubois
Posted by developer:
 
Noted in 5.7.16, 8.0.1 changelogs.

For SLES packages, a typo in the installation script postamble
prevented some cleanup from occurring.
[28 Sep 2016 14:28] Paul Dubois
Posted by developer:
 
Noted in 5.7.17 (not 5.7.16) changelog.