Bug #82376 Remote Connections to MySQL Database cannot handle queries returning > 100 rows
Submitted: 28 Jul 2016 18:45 Modified: 29 Jul 2016 4:02
Reporter: Alexander Nied Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.6 build 511 CE 64 bits OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: freeze, large query, remote, ssh, workbench

[28 Jul 2016 18:45] Alexander Nied
Description:
I am connecting to a database over SSH using the typical ports (22 to the proxy machine, 3306 to the database).

If I run a query that returns over 100 rows it often (but not always crashes). Other users in my workplace can perform these queries with no problems. Sometimes when they perform the query & it works for them, I can also perform it no problem. What happens is that it starts the query but it never seems to finish. Eventually I give up and press the Stop button. This freezes MySQL workbench and I have to manually terminate the process.

I tried the same query but modified how many columns I was returning (limiting all to 1000 rows). 1 to 9 columns worked fine, but over 10 columns caused this bug to happen. I'm not sure if the # of bytes, # of rows, or # of cells causes the problem but it definitely relates to the size of the return set.

The same queries do work 100% of the time on other database GUIs, python, and php.

See this other bug report for other people experiencing this: http://bugs.mysql.com/bug.php?id=76909

How to repeat:
Remotely connect to database over SSH

Run query that returns >10 columns & > 1000 rows.

Happens for my computer >90% of the time, but not at all for other colleagues using MySQL workbench with similar configurations.

Suggested fix:
Things I've tried that did not fix the problem:
* Setting the Preference SQL Editor/SQL Execution Limit Rows on and off, and changing the # of the limit rows count
* Trying a different computer. It also happens on my Macbook Pro
* Uninstalling & reinstalling workbench
* Updating workbench
* Using different users to connect to the computer

I suspect it has to deal with how packets are transmitted over SSH. Maybe something bad happens & it cannot recover.
[29 Jul 2016 3:52] Umesh Shastry
Hello Alexander Nied,

Thank you for the report.
This is most likely duplicate of Bug #82291

Thanks,
Umesh
[29 Jul 2016 3:54] Umesh Shastry
Issue observed only when using Standard TCP/IP over SSH(doesn't matter AWS or even instance within LAN/WAN).
[29 Jul 2016 4:02] Alexander Nied
Yes it's probably the same problem as the other bug report on July 20, something wrong with the SSH connection.

It's also related to the bug that I linked to from 2015 (#76909) that still does not seem resolved.