Bug #8236 Conversion of Datetime to Timestamp
Submitted: 1 Feb 2005 11:55 Modified: 1 Feb 2005 14:14
Reporter: Tom Schindl Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / J Severity:S2 (Serious)
Version:3.1.6 OS:Microsoft Windows (WinXP)
Assigned to: CPU Architecture:Any

[1 Feb 2005 11:55] Tom Schindl
Description:
When selecting values from a Datetime-Field using jdbc-3.1.6 I get an exception like this:
Cannot convert value '1979-05-01 00:00:00.#' where # stands for the non-printable char \0 hence when trying to Integer.parseInt(timestampValue.substring(decimalIndex+1)) throws an NumberFormatException

How to repeat:
MySQL-4.1-Table with DATETIME-column

Suggested fix:
timestampValue = timestampValue.replace('\0','0') although maybe there something more serious wrong and the \0 should not have been read in?
[1 Feb 2005 12:01] Tom Schindl
the bug is not non-critical
[1 Feb 2005 14:14] Mark Matthews
This is a duplicate of BUG#7715, which is already fixed for 3.1.7. You can test the fix with a nightly snapshot of 3.1.x from http://downloads.mysql.com/snapshots.php