Bug #82288 mysqld_multi script error
Submitted: 20 Jul 2016 6:18 Modified: 20 Jul 2016 6:24
Reporter: yi cao Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any

[20 Jul 2016 6:18] yi cao
Description:
run mysqld_multi stop 1

mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'multi_admin'@'localhost' (using password: YES)'

How to repeat:
run mysqld_multi stop 1

Suggested fix:
https://github.com/mangege/mysql-server/commit/0b4a5d07afd55ce6e875693aa12d83fae307022e

# scripts/mysqld_multi.sh

@@ -213,7 +213,7 @@ sub defaults_for_group
  
    return () unless $my_print_defaults_exists;
  
 -  my $com= join ' ', 'my_print_defaults', @defaults_options, $group;
 +  my $com= join ' ', 'my_print_defaults -s', @defaults_options, $group;
    my @defaults = `$com`;
    chomp @defaults;
    return @defaults;
[20 Jul 2016 6:24] Umesh Shastry
Hello yi cao!

Thank you for the report.
This is most likely duplicate of Bug #77227.

Thanks,
Umesh