Bug #82258 Cannot Modify Users and Privileges
Submitted: 18 Jul 2016 2:36 Modified: 13 Jan 2017 4:30
Reporter: Joshua Turci Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S5 (Performance)
Version:6.2.3 OS:Mac OS X (unknown)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[18 Jul 2016 2:36] Joshua Turci
Description:
----[For better reports, please attach the log file after submitting. You can find it in /Users/joshuaturci/Library/Application Support/MySQL/Workbench/log/wb.log]

How to repeat:
Click on a user account

following error occurs:

Unhandled exception: DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'
[18 Jul 2016 5:30] Umesh Shastry
Thank you for taking the time to report a problem.  Unfortunately you are not using a current version of the product you reported a problem with -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions, please change the version on this bug report to the version you tested and change the status back to "Open".  Again, thank you for your continued support of MySQL.
[19 Aug 2016 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[12 Jan 2017 18:06] Roy Levien
Same error on 

macOS 10.12.2 (16C67)
mysql  Ver 14.14 Distrib 5.7.17
MySQL Workebch 6.2.4.12437
[13 Jan 2017 4:30] Umesh Shastry
Thank you for the feedback.  Unfortunately you are not using a current version(6.3.8 is GA, and you are still using 6.2.4) of the product you reported a problem with -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions, please change the version on this bug report to the version you tested and change the status back to "Open".  Again, thank you for your continued support of MySQL.
[19 Mar 2018 12:47] Patrick van den Bemt
Version 6.3.10 has different reported issues with the users and privileges panel. Therefore I did a rollback to 6.2.5 ; which has the issue reported by Joshua. Since 6.2.5 has got open issues I am stuck.
[11 Apr 2018 20:58] Jason Neal
Receiving same issue on latest release:  6.2.5 build 397 (64-bit community editioin)

I can open the 'Users and Privileges' section of the MySQL Workbench - but anytime I click on a user it gives me the error and I cannot edit anything.

Interestingly enough I can create new users and they show up if I close and reopen the window, but when I do the create option it throws the error when I hit 'Apply'.
[27 Sep 2018 10:02] Andreas Jansson
The bug is still here.
Running version 6.2.5.0 build 397 32 bit of MySQl Workbench. On Windows 7.

I'm new here... How can I set the status of this issue to "Open" as suggested above?
[27 Sep 2018 10:06] Umesh Shastry
Thank you for your feedback.  Unfortunately you are not using a current version of the product you reported a problem with -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/

Also we don't fix bugs in old versions, don't backport bug fixes, so need to check with latest version anyway. So, please, upgrade and inform us if problem still exists. If you are able to reproduce the bug with one of the latest versions, please change the version on this bug report to the version you tested and change the status back to "Open".  Again, thank you for your continued support of MySQL.