Bug #82040 Getting below error
Submitted: 29 Jun 2016 3:53 Modified: 29 Jun 2016 4:03
Reporter: Ragav Gopalrao Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:mysql workbench 6.2 OS:Any
Assigned to: CPU Architecture:Any

[29 Jun 2016 3:53] Ragav Gopalrao
Description:
[Window Title]
MySQL Workbench

[Main Instruction]
Restore Workspace

[Content]
Could not read contents of 'C:\Users\user\AppData\Roaming\MySQL\Workbench\sql_workspaces\localhost-2.autosave\'.
Failed to open file 'C:\Users\user\AppData\Roaming\MySQL\Workbench\sql_workspaces\localhost-2.autosave\': No such file or directory

How to repeat:
when i open mysql workbench or click on mysql icon it opens and also pops above error.
[29 Jun 2016 4:03] Umesh Shastry
Thank you for taking the time to report a problem.  Unfortunately you are not using a current version of the product you reported a problem with -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions, please change the version on this bug report to the version you tested and change the status back to "Open".  Again, thank you for your continued support of MySQL.

Thanks,
Umesh
[6 Jul 2017 7:28] EKTV EKTV
Hi, having the latest version 6.3 and this is still a problem for me.
[1 Oct 2017 16:49] Kane Thomas
It's also happening for me. Latest version too.

https://imgur.com/a/0Gk20
[1 Oct 2017 16:53] Kane Thomas
Figured out a solution!

Change your MySQL Workbench shortcut to "run program as administrator". It seems to be a permissions issue.