Bug #8201 Weird Server Output (Column-Names) on query from php4 and mysql_client
Submitted: 30 Jan 2005 9:52 Modified: 30 Jan 2005 14:23
Reporter: [ name withheld ] Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: MyISAM storage engine Severity:S3 (Non-critical)
Version:Win32 4.1.9-nt OS:Microsoft Windows (Win XP Home SP2)
Assigned to: Assigned Account CPU Architecture:Any

[30 Jan 2005 9:52] [ name withheld ]
Description:
 Dear Sirs and Madams,

an irritating MySQL-Error occured, that catched my eye only under Win32.

For particular Information I refer to the Server Output etc. below. Please see the softcopy of the mysql-client: The output is somewhat curious.

I use MySQL Win32 4.1.9-nt via TCP/IP

The error occured in use with php4 under debian 3.0.

My phpinfo-Output as you can see below.

  PHP Version 4.3.9-1 

System  Linux littlecap 2.4.27-1-386 #1 Fri Sep 3 06:24:46 UTC 2004 i586  
Build Date  Oct 5 2004 08:37:12  
Configure Command  '../configure' '--prefix=/usr' '--with-apxs2=/usr/bin/apxs2' '--with-regex=php' '--with-config-file-path=/etc/php4/apache2' '--disable-rpath' '--enable-memory-limit' '--disable-debug' '--with-layout=GNU' '--with-pear=/usr/share/php' '--enable-calendar' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-bcmath' '--with-bz2' '--enable-ctype' '--with-db4' '--with-iconv' '--enable-exif' '--enable-filepro' '--enable-ftp' '--with-gettext' '--enable-mbstring' '--with-pcre-regex=/usr' '--enable-shmop' '--enable-sockets' '--enable-wddx' '--disable-xml' '--with-expat-dir=/usr' '--with-xmlrpc' '--enable-yp' '--with-zlib' '--without-pgsql' '--with-kerberos=/usr' '--with-openssl=/usr' '--enable-dbx' '--with-mime-magic=/usr/share/misc/file/magic.mime' '--with-exec-dir=/usr/lib/php4/libexec' '--disable-static' '--with-curl=shared,/usr' '--with-dom=shared,/usr' '--with-dom-xslt=shared,/usr' '--with-dom-exslt=shared,/usr' '--with-zlib-dir=/usr' '--with-gd=shared,/usr' '--enable-gd-native-ttf' '--with-jpeg-dir=shared,/usr' '--with-xpm-dir=shared,/usr/X11R6' '--with-png-dir=shared,/usr' '--with-freetype-dir=shared,/usr' '--with-imap=shared,/usr' '--with-imap-ssl' '--with-ldap=shared,/usr' '--with-mcal=shared,/usr' '--with-mhash=shared,/usr' '--without-mm' '--with-mysql=shared,/usr' '--with-unixODBC=shared,/usr' '--with-recode=shared,/usr' '--enable-xslt=shared' '--with-xslt-sablot=shared,/usr' '--with-snmp=shared,/usr' '--with-sybase-ct=shared,/usr' '--with-ttf=shared,/usr' '--with-t1lib=shared,/usr'  
Server API  Apache 2.0 Handler  
Virtual Directory Support  disabled  
Configuration File (php.ini) Path  /etc/php4/apache2/php.ini  
PHP API  20020918  
PHP Extension  20020429  
Zend Extension  20021010  
Debug Build  no  
Thread Safety  disabled  
Registered PHP Streams  php, http, ftp, https, ftps, compress.bzip2, compress.zlib  

 This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies  

  
mysql
MySQL Support enabled 
Active Persistent Links  0  
Active Links  0  
Client API version  3.23.56  
MYSQL_MODULE_TYPE  external  
MYSQL_SOCKET  /var/run/mysqld/mysqld.sock  
MYSQL_INCLUDE  -I/usr/include/mysql  
MYSQL_LIBS  -L/usr/lib -lmysqlclient  

  Directive Local Value Master Value 
mysql.allow_persistent On On 
mysql.connect_timeout 60 60 
mysql.default_host no value no value 
mysql.default_password no value no value 
mysql.default_port no value no value 
mysql.default_socket no value no value 
mysql.default_user no value no value 
mysql.max_links Unlimited Unlimited 
mysql.max_persistent Unlimited Unlimited 
mysql.trace_mode Off Off 

php-output (user-defined)
::::::::::::::::::::::::::::::::::
Nachrichten 

--------------------------------------------------------------------------------
Fehler!
Bei Ausf├╝hren des Befehls:

SELECT UID, lfdnr, starttime, timeto, timefrom, missionsnummer FROM missionen where mission=2

ist ein Fehler aufgetreten:

Unknown MySQL error 
:::::::::::::::::::::::::::::::::::

Client (5.0.0) Output:
:::::::::::::::::::::::::::::::::::
 mysql> select UID, lfdnr, starttime, timeto, timefrom, missionsnummer from missi
onen where mission = 2;
+------+------+------------+------+-----+-----+
| )@   | !@   | !          | ☺    | !   | #B  |
+------+------+------------+------+-----+-----+
|    1 | 1    | 1107075806 | 60   | 120 | 7   |
|    1 | 1    | 1107075817 | 60   | 120 | 8   |
+------+------+------------+------+-----+-----+
2 rows in set (0.00 sec)

mysql> SELECT UID, lfdnr, starttime, timeto, timefrom, missionsnummer FROM missi
onen where mission=2;
+-----+-------+------------+--------+----------+----------------+
| UID | lfdnr | starttime  | timeto | timefrom | missionsnummer |
+-----+-------+------------+--------+----------+----------------+
|   1 |     1 | 1107075806 |     60 |      120 |              7 |
|   1 |     1 | 1107075817 |     60 |      120 |              8 |
+-----+-------+------------+--------+----------+----------------+
2 rows in set (0.00 sec)
:::::::::::::::::::::::::::::::::::

Server Config:
:::::::::::::::::::::::::::::::::::

How to repeat:
Just repeat the query...

My PHP-Prog crashes, when it tries to use the malformed Server output...

Restart is useless(Server, Machine).

You may want to see Server Config or a Dump. You can Email me, if you want to see.

Suggested fix:
?!?
[30 Jan 2005 14:23] Dean Ellis
This looks like a duplicate of bug #6511: http://bugs.mysql.com/bug.php?id=6511

If so, disabling query cache is a temporary workaround.  Fix should be pushed into 4.1.10 soon.