Bug #8184 GLib-CRITICAL **: file gdate.c: line 917 (g_date_set_dmy)
Submitted: 28 Jan 2005 17:30 Modified: 6 Jul 2005 10:19
Reporter: Mal Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.5 OS:Microsoft Windows (XP)
Assigned to: Vladimir Kolesnikov CPU Architecture:Any

[28 Jan 2005 17:30] Mal
Description:
This error just keeps repeating:

(process:3824): GLib-CRITICAL **: file gdate.c: line 917 (g_date_set_dmy): asser
tion `g_date_valid_dmy (day, m, y)' failed

(process:3824): GLib-CRITICAL **: file gdate.c: line 917 (g_date_set_dmy): asser
tion `g_date_valid_dmy (day, m, y)' failed

(process:3824): GLib-CRITICAL **: file gdate.c: line 917 (g_date_set_dmy): asser
tion `g_date_valid_dmy (day, m, y)' failed

...

How to repeat:
Launching the program..
[1 Feb 2005 15:22] Aleksey Kishkin
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.mysql.com/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Additional info:

was not be able to reproduce. What locale is on your computer? What did you do with query browser when that error messages appear?
[29 Apr 2005 2:29] David Snell
I submitted the duplicate bug 9701 for version 1.1.6

Problem continues with version 1.1.7

Message now reads:

(process:2404): GLib-CRITICAL **: file gdate.c: line 917 (g_date_set_dmy): assertion `g_date_valid_dmy (day, m, y)' failed

My Regional Setting is English(Australia).

The message appears once when Query Browser starts, then again every time a query in the the query entry box is executed (by pressing the Execute button or by double-clicking twice on a table name in the schema panel).

It does not appear when table editor executes a query.  For example, if I create a table using the table editor, the message will not appear.  If I create an identical table by typing a CREATE TABLE statement into the query box, the message will appear.

Is there anything else I can tell you?
[5 Jul 2005 17:21] Peter Moore
I can reproduce this bug on Windows 2000, with Query Browser 1.1.10.  It appears to be a corrupted history file for the user account.  As you can see in the exerpt below, <date_last_access> is somehow being populated with an SQL history entry, rather than a date.  Removing this corrupt history entry fixes the problem.

From "C:\Settings and documents\myuser\Application Data\MySQL\mysqlqb_history.xml":
---------------------------------------------------------------

<?xml version="1.0"?>
<history>
  <history_entry>
    <catalog/>
    <schema>pcs</schema>
    <sql>SELECT * FROM employee;</sql>
    <query_type>0</query_type>
    <date_last_access>select SHA('helloworld')</date_last_access>
  </history_entry>
</history>
[6 Jul 2005 1:01] David Snell
Removing the last history entry fixed mine too.  In my case it contained:

<date_last_access>date_last_access</date_last_access>
[6 Jul 2005 10:19] Vladimir Kolesnikov
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html
[13 Aug 2005 21:51] ayland
Hello, i had have the same problem.
When i removed the latest records from mysqlqb_history.xml, it started working.
Thank you
[8 Feb 2006 11:41] Kip Parker
I had the same error with a different solution. The error was correctly reported by MySQL Administrator when I right-clicked and selected "edit table data as being in mysqladmin_options.xml. I couldn't work out what was wrong so I deleted it all and restarted and everything worked OK. 

File contents were:

<?xml version="1.0"?>
<application_options>
  <group name="General">
    <property name="LastFileDialogPaths" value=""/>
  </group>
  <group name="GUISetup">
    <property name="SectionSidebarWidth" value="185"/>
    <property name="SectionSidebarHidden" value="0"/>
  </group>
  <group name="AdminUserManagement">
    <property name="ShowUserGlobalPrivileges" value="0"/>
    <property name="ShowUserTableColumnPrivileges" value="0"/>
  </group>
  <group name="AdminHealthGraphs">
    <property name="UsePeakLevel" value="1"/>
    <property name="ResetPeakLevel" value="1"/>
    <property name="PeakLevelResetTicks" value="30"/>
  </group>
  <group name="AdminBackups">
    <property name="AddDateTimeToBackupFiles" value="1"/>
    <property name="WriteBackupLog" value="0"/>
    <property name="BackupLogDir" value="C:\"/>
    <property name="BackupLogEntryAfterRows" value="0"/>
  </group>
  <group name="WindowPos">
    <property name="MainForm" value="x=221; y=15; w=847; h=640; s=0; m=0"/>
  </group>
</application_options>