Bug #81827 no stack trace on crash in freebsd
Submitted: 13 Jun 2016 8:47 Modified: 17 Jun 2016 18:17
Reporter: Shane Bester (Platinum Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:5.6 OS:FreeBSD (10 x64)
Assigned to: CPU Architecture:Any

[13 Jun 2016 8:47] Shane Bester
Description:
when mysqld segfaults, there is no stack trace on freebsd.  makes it hard to diagnose.

How to repeat:
all you get is this:

Version: '5.6.27-enterprise-commercial-advanced'  socket: 'sock'  port: 3333  MySQL Enterprise Server - Advanced Edition (Commercial)
08:44:14 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

key_buffer_size=8388608
read_buffer_size=131072
max_used_connections=5
max_threads=151
thread_count=5
connection_count=5
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 68057 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

[xx@xx ~/tmp/mysql-advanced-5.6.27-freebsd10.0-x86_64]$

Suggested fix:
write a stack trace ;)
[17 Jun 2016 18:17] Paul Dubois
Posted by developer:
 
Noted in 8.0.0 changelog.

For segmentation faults on FreeBSD, the server did not generate a
stack trace.
[28 Sep 2016 15:33] Paul Dubois
Posted by developer:
 
Noted in 5.6.35 (not 5.6.34), 5.7.17 (not 5.7.16) changelogs.