Bug #81780 Error getting ddl for object.
Submitted: 8 Jun 2016 19:28 Modified: 8 Jun 2016 20:43
Reporter: aaa dds Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.6 OS:Microsoft Windows (Windows 10)
Assigned to: CPU Architecture:Any
Tags: DDL, Lost connection

[8 Jun 2016 19:28] aaa dds
Description:
I have a MySql database in which i work using MySql Workbench.
All my colleagues that have upgraded to windows 10 have had the issue that i'll describe below:

->When editing a stored procedure in an open connection (remote server), you can only apply the changes once. Trying a second time shows an error (Error getting ddl for object, Lost Connection to MySql server during query)
->Trying 3 or more times gives "No changes detected"

To fix the problem the connection has to be closed and reopened, which is a pain because you can only do one at a time.

Working on Windows 7 works fine.

How to repeat:
I cannot reproduce this error, as it works fine when i create a new schema in the remote server.
[8 Jun 2016 20:43] aaa dds
Fixed, it was the windows firewall that was activated, and causing strange behaviors in the connection.