Bug #81730 ODBC/Connector 5.3.6 fails to install on OS X 10.11.5
Submitted: 5 Jun 2016 20:04 Modified: 6 Jun 2016 1:47
Reporter: Doug Grant Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5,3,6 OS:Mac OS X (10.11.5)
Assigned to: CPU Architecture:Any

[5 Jun 2016 20:04] Doug Grant
Description:
Here is the complete crash report:

Process:               myodbc-installer [26567]
Path:                  /Users/USER/Downloads/*/myodbc-installer
Identifier:            myodbc-installer
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        bash [26558]
Responsible:           Terminal [26544]
User ID:               501

Date/Time:             2016-06-05 15:44:40.126 -0400
OS Version:            Mac OS X 10.11.5 (15F34)
Report Version:        11
Anonymous UUID:        B76336F3-55CD-60A1-AA90-E22784806DAB

Sleep/Wake UUID:       214EF3F8-3E36-4051-B3DD-0364878C0210

Time Awake Since Boot: 680000 seconds
Time Since Wake:       710 seconds

System Integrity Protection: disabled

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /Volumes/hd2/pb2/build/sb_0-18231254-1457619324.6/unixODBC-2.3.2-osx10.11-x86-64bit/lib/libodbc.2.dylib
  Referenced from: /Users/USER/Downloads/*/myodbc-installer
  Reason: image not found

Binary Images:
    0x7fff68980000 -     0x7fff689b725f  dyld (360.22) <A468D85E-D8D6-3461-8C99-49D3B9ACFC63> /usr/lib/dyld

 

How to repeat:
Download the file mysql-connector-odbc-5.3.6-osx10.11-x86-64bit.tar,
unpack it, then run the program myodbc-installer. 

Suggested fix:
The file in question,  libodbc.2.dylib, should not be referenced, at least not the way it was refenced.
[5 Jun 2016 23:40] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=81113.
[6 Jun 2016 1:47] Doug Grant
Sorry; I have been shown that this is a duplicate of 81113, which did not show up when I searched for a duplicate. Perhaps I should not have said OS x 10.11.5 which was not the exact
content of the other bug report. It is not clear how specific one should be in searching for duplicates. There seem to be several other duplicates!