Bug #81728 mysql-installer-community-5.7.13.0.msi does not list 5.7.13 as an option
Submitted: 5 Jun 2016 10:07 Modified: 2 Aug 2016 22:07
Reporter: Anthony Marston Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S1 (Critical)
Version:5.7.13 OS:Microsoft Windows (Windows 7 64bit)
Assigned to: CPU Architecture:Any

[5 Jun 2016 10:07] Anthony Marston
Description:
I have just downloaded mysql-installer-community-5.7.13.0.msi so that I can upgrade my current installation from 5.7.12, but when I run the program it does not show version 5.7.13 as an available option. I have tried updating the catalog, but it says that no new versions are available. Why is this happening?

How to repeat:
Install version 5.7.12, then run mysql-installer-community-5.7.13.0.msi to upgrade it.

Suggested fix:
Make sure that the program which is supposed to upgrade to a new version actually lists that version as an option.
[5 Jun 2016 10:38] Peter Laursen
Same here.
[6 Jun 2016 5:19] Chiranjeevi Battula
Hello Anthony Marston,

Thank you for the bug report.

Thanks,
Chiranjeevi.
[6 Jun 2016 5:19] Chiranjeevi Battula
Screenshot.

Attachment: 81728_community.JPG (image/jpeg, text), 42.18 KiB.

[6 Jun 2016 5:20] Chiranjeevi Battula
Screenshot.

Attachment: 81728_commercial.JPG (image/jpeg, text), 61.68 KiB.

[7 Jun 2016 18:20] Igor Kuznetsov
Same situation on server 2012. Cant upgrade 5.7.12 to 5.7.13 via installer.

Pic - https://pp.vk.me/c631227/v631227967/2e405/5vfF5YTOjoU.jpg
[9 Jun 2016 8:49] Peter Laursen
same thing with 5.5.0
[14 Jun 2016 17:18] Javier Rivera Zavala
Posted by developer:
 
I've tried the above described steps and been unable to reproduce.

1. Downloaded the installer bundle that includes MySQL Server 5.7.12 msi and installed it.
2. Downloaded the latest installer from http://dev.mysql.com/downloads/installer/ (5.7.13) and run it.

The installed server 5.7.12 shows an icon in the dashboard that it has upgrades available.

Probably the catalog was not yet updated when this bug was raised?
[14 Jun 2016 17:19] Javier Rivera Zavala
Displaying Upgrades Available

Attachment: UpgradesAvailable.png (image/png, text), 21.83 KiB.

[14 Jun 2016 21:30] Obermüller Andreas
Hello,

I retested the bug in our company network and at home but it is still present.
Which Version of MySQl Installer do you see if you press the Questionmarkbutton?
I have 1.4.16.0.
If i click on Catalog to update the Cataltog it is all running without any errors but no new updates are available.

Is it maybe a regional problem that some webservers are not up to date? I'm sitting here in Europe - Germany.

Another idea: Where is the old Catalog stored? Maybe it is working if we delete the old catalog and let create a new one.
[15 Jun 2016 7:04] Shane Bester
i'm sure i wrote this in my original bug report.
if this is pulling data from some http server,  then you need to set correct http headers to avoid proxy servers caching etc.  please consider that.
[16 Jun 2016 9:14] Anthony Marston
This is still not working as the installer does not show any versions available after 5.7.12. I have tried to update the catalog manually, but it says that nothing has changed since 27/05/2016
[16 Jun 2016 9:14] Anthony Marston
screenshot from Update Catalog

Attachment: update-catalog.png (image/png, text), 12.86 KiB.

[16 Jun 2016 9:20] Peter Laursen
Same for me (on Win10) - and I also have with latest Workbench release BTW.

This is an ever-repeating problem and similar has been reported dozens of times over the last few years. 

- Peter
- not a MySQL/Oracle eprson
[17 Jun 2016 10:36] David Beroff
I have a similar, and likely related, issue with trying to upgrade just
MySQL Workbench from 6.3.6 to 6.3.7, when trying both 
mysql-installer-web-community-5.7.13.0.msi and 
mysql-installer-community-5.7.13.0.msi; the catalog does not show any 
available upgrades, even when updated manually.

The installation from mysql-workbench-community-6.3.7-winx64.msi
(Windows (x86, 64-bit), MSI Installer 6.3.7) fails in a different fashion,
(Bug #81905), however I found a reasonable workaround was that I *was* able 
to successfully install MySQL Workbench 6.3.7 from
mysql-workbench-community-6.3.7-win32.msi
(Windows (x86, 32-bit), MSI Installer 6.3.7).  (Hope that helps somebody!)
[20 Jun 2016 14:19] Matt Younger
I'm having the same issue as well running MySQL Installer version 1.4.16.0.
[22 Jun 2016 3:12] Javier Rivera Zavala
I cannot reproduce the bug on my environment. If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.
[22 Jun 2016 8:29] Peter Laursen
What more informaton would be useful here?
[22 Jun 2016 9:33] Anthony Marston
I have given you all the information that is available. I cannot upgrade from 5.7.12 to 5.7.13 as your software refuses to load the catalog which shows that 5.7.13 is available as an upgrade.

You need to look at your software to find out under what circumstances this can happen. I cannot tell you what is causing this as there is no error message. The only message that I can see is that there have been no updates to the catalog since 27/05/2016. Why can't your software recognise that a later version of the catalog *IS* available?
[22 Jun 2016 12:23] Obermüller Andreas
Interessting point is:
yesterday it didn't worked for me (I tested it nearly every day the past days)
todays morning, after the bug got "closed" - it worked on the Company Network and on my private Network.
[22 Jun 2016 12:25] Peter Laursen
It still doesn't for me.
[22 Jun 2016 12:55] Matt Younger
It looks like this has been corrected now.  When I update the catalog, it now shows that there is an upgrade available for 5.7.13.
[22 Jun 2016 13:01] Peter Laursen
It still doesn't for me. And updatign catalog tells that there is no update.

I think this is a proxy/cache issue. Does every catalog update have a unique URL and name?
[22 Jun 2016 13:02] Matt Younger
Peter,

Not sure about whether they have unique URLs or not, but couldn't you just check your proxy logs to see if addresses are being denied?
[22 Jun 2016 13:04] Peter Laursen
I don't operate a proxy myself. But my ISP may have (probably has) and also Internet servers may have.
[26 Jun 2016 9:06] Anthony Marston
I have just run the installer again, but this time it recognised that an updated catalog existed so it allowed me to upgrade. This raises the following questions:

1) What URL does the installer use to check the latest catalog?
2) Is it possible to change this URL to one that not cached and out-of-date?
3) Is it possible to download the latest catalog manually and overwrite the one used by the installer?

This would then get rid of the problem where some people cannot access the latest catalog without knowing the reason why. This would also get rid of the excuse "cannot reproduce" as it is access to the latest catalog which is the problem and not the code which accesses the catalog.
[26 Jun 2016 10:41] Peter Laursen
I second that! Please provide the manifest as a file for download (and explain how to replace it on systems affected).

And the problem is STILL NOT resolved for me.
[2 Aug 2016 22:07] Philip Olson
Posted by developer:
 
Fixed as of the upcoming MySQL Installer 1.4.17 release, and here's the changelog entry:

The manifest would sometimes fail to find a newer MySQL Server version.

Thank you for the bug report.

I do not know the specifics of this fix, but hopefully a developer will refer to it
here. Perhaps it's a fix to help Installer navigate the world of Proxy/Cache.