Bug #81546 Workbench Migration weird error when trying to connect using an ODBC FreeTDS
Submitted: 23 May 2016 15:16 Modified: 18 Feb 2020 22:57
Reporter: Kenny Gryp Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Migration Severity:S3 (Non-critical)
Version:6.3.6, 8.0.19 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[23 May 2016 15:16] Kenny Gryp
Description:
While trying to connect to Sybase using various ODBC Methods (i hope we all agree ODBC is a pain to handle, especially under windows), I get very confusing error messages:

Unhandled Exception: Exception calling mforms method 'mforms::Utilities::show_message': bad conversion.

The problem in this case was that we did not correctly configure the  FreeTDS driver. 

How to repeat:
Attached you can see a screenshot.

- Start Migration
- Source Sybase
- Connection Method: ODBC (FreeTDS)
- Click Test Connection
- Get same error.

Suggested fix:
I was hoping to get a better error message than this.

I don't know the code but it looks like a displaying error of some kind.
[23 May 2016 15:16] Kenny Gryp
Error.png

Attachment: image002.png (image/png, text), 46.63 KiB.

[23 May 2016 21:19] MySQL Verification Team
Thank you for the bug report. This bug isn't related to bug http://bugs.mysql.com/bug.php?id=81545 (Migration of Sysbase) which can be commented all the issues in same report. Thanks.
[23 May 2016 21:41] Kenny Gryp
This bug is not related to #81545, DelimitIdentifier=NO with this setup.
[25 May 2016 11:29] MySQL Verification Team
Hello Kenny Gryp,

Thank you for the report and feedback!

Thanks,
Umesh
[13 Sep 2016 6:49] Leonidas Liakos
I also get the same message when I'm trying to connect to MS Sql Server using Sql Server Driver.
[23 Apr 2017 17:56] Alan Aranda
Hi, try to use Connection Method: ODBC(native) and it will work.
[18 Feb 2020 22:57] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.21 release, and here's the proposed changelog entry from the documentation team:

A Sybase database migration with the ODBC (FreeTDS) connection method
produced an exception when the connection was tested.

Thank you for the bug report.
[22 May 2020 12:10] MySQL Verification Team
Bug #99056 marked as duplicate of this one.