Bug #81518 ROOT USER CREATED WITH AUTH_SOCK PLUGIN EVEN ROOT PWD IS NOT BLANK
Submitted: 20 May 2016 13:23 Modified: 31 May 2016 15:15
Reporter: Ramana Yeruva Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.7.13 OS:Any
Assigned to: CPU Architecture:Any

[20 May 2016 13:23] Ramana Yeruva
Description:
During server release testing of 5.6.31,5.7.13, new platform Ubuntu16.04 added for repos and observed that Bug#22594846 is reproducible with Ubuntu16.04 5.7.13 commercial repo packages.It looks like same fix should be ported to Ubuntu16.04 repos of 5.7.13

How to repeat:
refer steps:Bug#22594846

Suggested fix:
as that of Bug#22594846
[31 May 2016 15:15] Paul Dubois
Posted by developer:
 
Noted in 5.7.14 changelog.

Ubuntu packages create the root user account using the auth_socket
authentication plugin to achieve secure-by-default installation if
installation was done with a blank root password. However,
auth_socket was being used even if the password was not blank.