Bug #81152 error 1778 couldn`t execute statement with implicit commit
Submitted: 20 Apr 2016 8:13 Modified: 28 Apr 2016 9:59
Reporter: abc true vision Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Row Based Replication ( RBR ) Severity:S3 (Non-critical)
Version:5.7.12 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: slave sql ruuning stopped due to slave relay log rotation

[20 Apr 2016 8:13] abc true vision
Description:
# at 12433
#160420  9:28:21 server id 1000  end_log_pos 8567874 CRC32 0x1c6032ec 	GTID	last_committed=13647	sequence_number=13648
SET @@SESSION.GTID_NEXT= '936028d7-04b9-11e6-ac6d-d4ae52cbf622:4432'/*!*/;
# at 12498
#160420  9:28:21 server id 1000  end_log_pos 8567937 CRC32 0xbdb35e0f 	Query	thread_id=55	exec_time=4294966951	error_code=0
SET TIMESTAMP=1461133701/*!*/;
BEGIN
/*!*/;
# at 12561
#160420  9:28:21 server id 1000  end_log_pos 8568029 CRC32 0xc33a03cc 	Table_map: `abc`.`warehouses_stocks_log_data` mapped to number 1116
# at 12653
#160420  9:28:21 server id 1000  end_log_pos 8568110 CRC32 0xd4ef04f8 	Table_map: `abc`.`warehouses_stocks` mapped to number 1104
# at 12734
#160420  9:28:21 server id 1000  end_log_pos 8568274 CRC32 0x5f985084 	Update_rows: table id 1104
# at 12898
#160420  9:28:21 server id 1000  end_log_pos 8568392 CRC32 0xcad285fc 	Write_rows: table id 1116 flags: STMT_END_F
### UPDATE `abc`.`warehouses_stocks`
### WHERE
###   @1=100000000000052850
###   @2=100000060446
###   @3=20924
###   @4=30
###   @5=0
###   @6=1
###   @7=1461069345
###   @8=NULL
###   @9='HQ WAREHOUSE'
###   @10='ASHIK'
###   @11=1
### SET
###   @1=100000000000052850
###   @2=100000060446
###   @3=20924
###   @4=23
###   @5=0
###   @6=1
###   @7=1461069345
###   @8=1461133701
###   @9='HQ WAREHOUSE'
###   @10='ASHIK'
###   @11=3
### INSERT INTO `abc`.`warehouses_stocks_log_data`
### SET
###   @1='16741875484626780330'
###   @2=100000060446
###   @3=20924
###   @4=30
###   @5=0
###   @6=23
###   @7=0
###   @8='HQ WAREHOUSE'
###   @9=1461133701
###   @10='ASHIK'
###   @11=2
###   @12=3
# at 13016
#160420  9:28:21 server id 1000  end_log_pos 8568423 CRC32 0x09fc098b 	Xid = 162044
COMMIT/*!*/;
# at 13047
#160420  9:28:21 server id 1000  end_log_pos 8568488 CRC32 0xec9cd354 	GTID	last_committed=13648	sequence_number=13649
SET @@SESSION.GTID_NEXT= '936028d7-04b9-11e6-ac6d-d4ae52cbf622:4433'/*!*/;
# at 13112
#160420  9:28:21 server id 1000  end_log_pos 8568551 CRC32 0x2b059bc7 	Query	thread_id=55	exec_time=4294966951	error_code=0
SET TIMESTAMP=1461133701/*!*/;
BEGIN
/*!*/;

this is correptued relay log
after restart server it work

every 1 hour i need to restart server due to channel stopped displaying error 1778

error 1778 couldn`t execute statement with implicit commit

this is conf file

sync_master_info = 1
sync_relay_log = 1
sync_relay_log_info = 1
master-info-file = master.info
replicate-do-db = abc
enforce_gtid_consistency = ON
log-bin = ph2-bin
binlog_format = ROW
master_info_repository = TABLE
log_slave_updates
group_concat_max_len = 2048
sync_binlog = 1
max_heap_table_size = 2097152000
collation-server = utf8_unicode_ci
binlog-do-db = abc
gtid-mode = ON
relay-log-info-repository = TABLE
relay_log_purge
relay_log_recovery
sync_binlog = 1

How to repeat:
error 1778 couldn`t execute statement with implicit commit

Suggested fix:
i don`t know
[28 Apr 2016 9:59] MySQL Verification Team
Hello!

Thank you for the report.
This is most likely duplicate of Bug #81119

Thanks,
Umesh