Bug #81144 Slave not syncing with master
Submitted: 19 Apr 2016 19:41 Modified: 15 Oct 14:17
Reporter: Vikram Mehta Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Replication Severity:S1 (Critical)
Version:5.6.26 OS:CentOS
Assigned to: Bogdan Kecman CPU Architecture:Any

[19 Apr 2016 19:41] Vikram Mehta
Description:
I've replicated two servers (a master and a slave). When I'm looking at mysqlfailover, everything seems OK. When I shutdown the master, the slave becomes the new master, which is as it should be. 

However, when I add the old master as the new slave, and check mysqlfailover, I get SQL thread is not running., Slave has 25 transactions behind master.

When I check the slave status within the mysql shell, the Slave_IO_Running is running, but Slave_SQL_Running is not.

How to repeat:
As stated above:
1) Replicate a master and slave. 
2) Failover to slave.
3) Replicate old master as new slave.
4) New slave is transactions behind master.
[15 Oct 14:17] Bogdan Kecman
Hi,

I cannot reproduce this.

How did you return "recovered/ex master" MySQL Server back into the topology?