Bug #81113 Installation fails on OSX El Capitan
Submitted: 17 Apr 2016 23:11 Modified: 10 Apr 2017 22:38
Reporter: Attila Széles Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:5.3.6-osx10.11-x86-64bit OS:Mac OS X (El Capitan)
Assigned to: CPU Architecture:Any
Tags: El Capitan, install fails, ODBC Connector

[17 Apr 2016 23:11] Attila Széles
Description:
The installation from DMG always unsuccessful.
By manual installation i got warning : 
Library not loaded: /Volumes/hd2/pb2/build/sb_0-18231254-1457619324.6/unixODBC-2.3.2-osx10.11-x86-64bit/lib/libodbc.2.dylib 
Referenced from: /usr/local/bin/myodbc-installer 
Reason: image not found 
Trace/BPT trap: 5 

How to repeat:
Always
[18 Apr 2016 14:59] Miguel Solorzano
Error Dialog

Attachment: odbc_install.png (image/png, text), 275.25 KiB.

[18 Apr 2016 15:00] Miguel Solorzano
Thank you for the bug report.
[24 Apr 2016 22:47] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=81190 marked as duplicate of this one.
[4 May 2016 13:21] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=81310 marked as duplicate of this one.
[7 May 2016 12:58] Tony Dubach
Anyone any idea of an ETA for a solution on this one. I'm also affected by it. Exact same behavior as described by Attila. My only alternativ would be a payd driver from Actual Technologies, which seems to be working.

Thanks for any help anyway.
[24 May 2016 18:49] Gonzalo Moreno
This worked for me:
$ brew install unixodbc
[5 Jun 2016 15:08] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=81726 marked as duplicate of this one.
[5 Jun 2016 23:40] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=81730 marked as duplicate of this one.
[5 Jun 2016 23:40] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=81730 marked as duplicate of this one.
[28 Jun 2016 6:08] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=82023 marked as duplicate of this one.
[5 Jul 2016 14:15] Attila Széles
Is going to happen with this fail?
[2 Sep 2016 15:35] Andrea De Gouveia De Sá
Is there any news about this bug? could somebody please recommend alternative solutions? Thank you!
[10 Sep 2016 18:01] Joseph Kolnik
Has anyone resolved this issue.  I get the same error.
[12 Sep 2016 8:06] Lawrence Raisanen
For anyone else who simply cannot wait for fix, I also used the Actual Tech. drivers (but they are $39) which are working great and installed as easy as everything on a mac.  Here is the link: http://www.actualtech.com/product_opensourcedatabases.php
[12 Sep 2016 13:31] Bogdan Degtyariov
The Connector/ODBC 5.3.6 needs UnixODBC.
Please install UnixODBC 2.3.2 in your OSX and try again.
[23 Oct 2016 0:41] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83482 marked as duplicate of this one.
[1 Dec 2016 15:06] Rene Lopez
It's been since April and still no movement on this?
[21 Dec 2016 16:07] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84302 marked as duplicate of this one.
[15 Feb 2017 7:24] J T
Having the same error message. Kind of frustrating to see that this was initially raised in April 2016 and there is no real response from oracle.
[15 Feb 2017 11:30] Bogdan Degtyariov
This problem has been resolved in Connector/ODBC 5.3.7
The DMG package installs in OSX.
We moved it from using UnixODBC (which was kind of unnatural for OSX) back to iODBC.
[22 Feb 2017 11:39] loic delafontaine
Hello,

For me, this problem was not resolved in Connector/ODBC 5.3.7.

I have the same error message.

Thanks
[22 Feb 2017 12:34] jc otero
Hello,

In my case the same thing happens to me, with version 5.3.7 I also have the same error message with the installation.

Thanks
[23 Feb 2017 1:48] Bogdan Degtyariov
The problem might occur if iODBC is not found.
Do you have iODBC installed in your OSX El Capitan?
[23 Feb 2017 10:55] loic delafontaine
It's works for me after i have installed iODBC.
Thanks
[15 Mar 2017 10:18] Bogdan Degtyariov
Posted by developer:
 
The version 5.3.7 is linked against iODBC, so the installation problem is resolved
[10 Apr 2017 22:38] Daniel So
Posted by developer:
 
Added the following into the C/ODBC 5.3.7 changelog:

"Connector/ODBC could not be installed on OS X using the installer provided with the .dmg file unless unixODBC had been installed on the system. With this fix, Connector/ODBC is now built to work with the iODBC manager instead. Installation now only requires iODBC to be on the system."
[13 Nov 2017 10:56] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=88449 marked as duplicate of this one.
[22 Nov 2017 20:53] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=88614 marked as duplicate of this one.