Bug #81074 semaphore wait assertion failure
Submitted: 13 Apr 2016 21:56 Modified: 13 Apr 2016 22:35
Reporter: monty solomon Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version: OS:CentOS
Assigned to: CPU Architecture:Any

[13 Apr 2016 21:56] monty solomon
Description:
MySQL crashed and suggested I submit a bug report.

InnoDB: Error: semaphore wait has lasted > 600 seconds
InnoDB: We intentionally crash the server, because it appears to be hung.

mysql  Ver 14.14 Distrib 5.6.25-73.1, for Linux (x86_64) using  6.0
5.6.25-73.1-log Percona Server (GPL), Release 73.1, Revision 07b797f

Linux plain-union 3.18.26-83.el6.x86_64 #1 SMP Mon Jan 25 18:39:22 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

CentOS release 6.7 (Final)

How to repeat:
Here is the output from the error log.

InnoDB: ###### Diagnostic info printed to the standard error stream
InnoDB: Error: semaphore wait has lasted > 600 seconds
InnoDB: We intentionally crash the server, because it appears to be hung.
2016-04-13 07:31:21 7fb63c973700  InnoDB: Assertion failure in thread 140420677318400 in file srv0srv.cc line 2128
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
/usr/sbin/mysqld(my_print_stacktrace+0x2c)[0x8cea7c]
/usr/sbin/mysqld(handle_fatal_signal+0x461)[0x655fa1]
/lib64/libpthread.so.0[0x374820f7e0]
/lib64/libc.so.6(gsignal+0x35)[0x3747e32625]
/lib64/libc.so.6(abort+0x175)[0x3747e33e05]
/usr/sbin/mysqld[0x9ad3df]
/lib64/libpthread.so.0[0x3748207aa1]
/lib64/libc.so.6(clone+0x6d)[0x3747ee893d]
160413 07:36:20 mysqld_safe Number of processes running now: 0
160413 07:36:20 mysqld_safe mysqld restarted

Suggested fix:
Unknown
[13 Apr 2016 22:35] Miguel Solorzano
Thank you for the bug report. Duplicate of bug http://bugs.mysql.com/bug.php?id=73890.