Bug #80868 Cannot Select Date Type
Submitted: 28 Mar 2016 16:06 Modified: 4 May 2016 11:22
Reporter: Maximilian Schmidt Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:6.9.8 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: Selecting

[28 Mar 2016 16:06] Maximilian Schmidt
Description:
When Selecting Values from a InnobDB MySql Server wich aren´t the attribute unsigned they can´t be selected in a Windows Universal app the Exception:

{"Destination array is not long enough to copy all the items in the collection. Check array index and length."}	System.Exception {System.ArgumentException}

The problem is int can be set as unsigned but it gives no chance to get Date values from the database

How to repeat:
Create a innobDB Database with a Date or a int value without attributes and try to select them.
[29 Mar 2016 5:31] Maximilian Schmidt
I forget I use the RT Reference and use Windows UWA for the Repeating
[29 Mar 2016 9:34] Chiranjeevi Battula
Hello Maximilian Schmidt,

Thank you for the bug report.
Could you please provide repeatable test case (exact steps/sample project, create table statements etc. - please make it as private if you prefer) to confirm this issue at our end?

Thanks,
Chiranjeevi.
[29 Mar 2016 17:10] Maximilian Schmidt
I have an Stackoverflow post with the table creation and the query i tried.

http://stackoverflow.com/questions/36257905/mysql-only-get-varchar-from-database

Greetings Max
[4 May 2016 11:22] Chiranjeevi Battula
Hello Maximilian Schmidt

Thank you for your feedback.
I could not repeat the issue on Visual Studio 2015 (C#.Net), MySQL Connector/Net 6.9.8 but not seeing any issues with selecting different data types.
If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.