Bug #80760 Reverse Engineer fails to load table which has "WITH PARSER" clause
Submitted: 16 Mar 2016 8:38 Modified: 21 Mar 2018 15:27
Reporter: tsubasa tanaka (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:6.3.6 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any

[16 Mar 2016 8:38] tsubasa tanaka
Description:
Reverse Engineer function in MySQL Workbench 6.3.6 fails to import the table which has  Full Text Index with "WITH PARSER" clause.

Both "WITH PARSER ngram" and "WITH PARSER mecab".

How to repeat:
```
mysql57> CREATE DATABASE d1;
Query OK, 1 row affected (0.01 sec)

mysql57> CREATE TABLE d1.t1 (val varchar(32), FULLTEXT KEY(val) WITH PARSER ngram);
Query OK, 0 rows affected (0.56 sec)

mysql57> SHOW CREATE TABLE d1.t1\G
*************************** 1. row ***************************
       Table: t1
Create Table: CREATE TABLE `t1` (
  `val` varchar(32) COLLATE utf8mb4_bin DEFAULT NULL,
  FULLTEXT KEY `val` (`val`) /*!50100 WITH PARSER `ngram` */
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_bin
1 row in set (0.00 sec)
```

Launch MySQL Workbanch and click "File" => "New Model" => "Database" => "Reverse Engineer", and import d1 schema.

You can see "Summary of Reverse Engineered Objects: - empty schema 'd1'" at the end of Reverse Engineer wizard.
[16 Mar 2016 8:39] tsubasa tanaka
Woops, MySQL Server Version is 5.7.11.
[16 Mar 2016 9:42] Umesh Shastry
Hello Tanaka-San,

Thank you for the report.
Verified as described with WB 6.3.6(schema created on 5.7 instance, WB model default target MySQL version set to 5.7) on Win7.

Thanks,
Umesh
[28 Feb 2017 9:15] Mike Lischke
Bug #85219 was set as duplicate of this one.
[28 Feb 2017 9:24] Mike Lischke
Bug #83791 was set as duplicate of this one.
[21 Mar 2018 15:27] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.11 release, and here's the changelog entry:

The Reverse Engineer Database wizard excluded tables in which the WITH
PARSER clause was present.

Thank you for the bug report.