Bug #80437 Unhandled Exception during installation of MySQL Server 5.7
Submitted: 19 Feb 2016 4:35 Modified: 19 Feb 2016 7:59
Reporter: Mohit Wangu Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:5.7 OS:Windows (Windows 7 Enterprise)
Assigned to: CPU Architecture:Any

[19 Feb 2016 4:35] Mohit Wangu
Description:
Unhandled Exception during installation of MySQL Server

How to repeat:
1. I had first installed MySQL Workbench but could not see any schema available
2. If i tried to create a schema, the application throws an error and exits

3. Next i tried to install the MySQL Community Edition (GPL),the installation notified of two manual installation requirements which i ignored at the time and proceeded.

4. The install completed and i was able to connect to schema Sakila and run queries on Actor table.

5. Overnight there was no activity on MySQL and morning i got an error that MySQL has gone away.

6. I tried to reconnect but was not successful.

7. So i uninstalled MySQL and ever since i try to install again,
i see and unhandled exception at the last step of the installation but if i proceed further , the workbench launches but schema are not available.

8. Error occurs on all types of installation : Full, Custom etc
[19 Feb 2016 5:54] Mohit Wangu
Another issue is of the installation path: 

1. During the second and all subsequent installation attempts, i see a warning on the install path and data path.

2. I can change the path for both but even with the new path selected, it again shows that the path already exists !!!

3. I don't have access to Pathdata folder so i'm not able to clear its contents.
[19 Feb 2016 7:04] Chiranjeevi Battula
Hello Mohit Wangu,

Thank you for the bug report.
Could you please provide exact error message/screenshot to confirm this issue at our end?
It seems you are not uninstall completely in your system, Could you please do completely remove MySQL(using control panel) and reinstall from below link.

Please download MySQL latest version.
https://dev.mysql.com/downloads/mysql

Thanks,
Chiranjeevi.
[19 Feb 2016 7:12] Mohit Wangu
Error Screenshot

Attachment: Capture.JPG (image/jpeg, text), 70.09 KiB.

[19 Feb 2016 7:13] Mohit Wangu
screenshot added
[19 Feb 2016 7:23] Mohit Wangu
Exception Screenshot

Attachment: Capture2.JPG (image/jpeg, text), 28.81 KiB.

[19 Feb 2016 7:23] Mohit Wangu
Error Log : 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Runtime.InteropServices.COMException (0x800706D9): There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9)
   at NetFwTypeLib.INetFwPolicy2.get_CurrentProfileTypes()
   at WexInstaller.Core.Firewall.Policy..ctor()
   at WexInstaller.Plugins.Server.MySqlServerSettings.IsRuleEnabled(String port)
   at WexInstaller.Plugins.Server.MySqlServerSettings.LoadIniSettings()
   at WexInstaller.Core.Controllers.ControllerSettings.LoadState()
   at WexInstaller.Core.Controllers.ProductConfigurationController.LoadState()
   at WexInstaller.Wizards.Common.ConfigOverviewPage.Activate()
   at WexInstaller.Wizards.Wizard.ActivatePage()
   at WexInstaller.Wizards.AddProductsWizard.AddWizard.UpdateWizardPage(Int32 newPage)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
MySQLInstaller
    Assembly Version: 1.4.14.0
    Win32 Version: 1.4.14.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer%20for%20Windows/MySQLInstaller.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
MySQLInstaller.Core
    Assembly Version: 1.4.14.0
    Win32 Version: 1.4.14.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer%20for%20Windows/MySQLInstaller.Core.DLL
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
WindowsBase
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/WindowsBase/v4.0_4.0.0.0__31bf3856ad364e35/WindowsBase.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
StandardPlugins
    Assembly Version: 1.4.14.0
    Win32 Version: 1.4.14.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer%20for%20Windows/StandardPlugins.DLL
----------------------------------------
System.ServiceProcess
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ServiceProcess/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.ServiceProcess.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System.Management
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1055.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Management/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
[19 Feb 2016 7:59] Chiranjeevi Battula
Hello Mohit Wangu,

Thank you for your feedback.
This is most likely duplicate of Bug #74210, please see Bug #74210

Thanks,
Chiranjeevi.
[21 Jun 2016 9:51] deepak verma
Hi Mohit 
Did u get any solution for this issue ?