Bug #8041 umlauts are stripped from table names
Submitted: 20 Jan 2005 11:37 Modified: 23 Feb 2005 17:14
Reporter: Jan Kneschke Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.1.9 OS:Microsoft Windows (Windows)
Assigned to: Alexander Barkov

[20 Jan 2005 11:37] Jan Kneschke
Description:
Creating a table and using characters from a unspecified character set results in a stripped tablename.

How to repeat:
Take a DOS-box on windows (using cp850 at least in western europe):

mysql> show variables like "chara%";
+--------------------------+--------------------------+
| Variable_name            | Value                    |
+--------------------------+--------------------------+
| character_set_client     | latin1                   |
| character_set_connection | latin1                   |
| character_set_database   | latin1                   |
| character_set_results    | latin1                   |
| character_set_server     | latin1                   |
| character_set_system     | utf8                     |
| character_sets_dir       | C:\mysql\share\charsets/ |
+--------------------------+--------------------------+

mysql> create table äfoo ( a int );
Query OK, 0 rows affected (0.05 sec)

root@localhost [mysql]> show tables like "%foo";
+------------------------+
| Tables_in_mysql (%foo) |
+------------------------+
| foo                    |
+------------------------+
1 rows in set (0.00 sec)

root@localhost [mysql]> create table foo ( a int );
ERROR 1050 (42S01): Table 'foo' already exists

Suggested fix:
the 'ä' that you see is a _cp850'ä' [0x84] while the character_set_client says _latin1 mapping it to a non-existing/control character. 

Proving a control character should result in an ERROR here.
[20 Jan 2005 13:06] Godofredo Miguel Solorzano
Thank you for the bug report I was able to repeat. 
This only happens on Windows server version.
[25 Jan 2005 13:53] Frank Mussmann
This happens also on a Windows 2K machine without SPs. :-)
[22 Feb 2005 6:00] Alexander Barkov
Fixed in 4.1.11 and 5.0.3
[23 Feb 2005 17:14] Paul Dubois
Noted in 4.1.11, 5.0.3 changelogs.