Bug #80339 InnoDB: Assertion failure in thread 140312504092480 in file buf0dblwr.cc line 55
Submitted: 11 Feb 2016 11:20 Modified: 20 May 2017 11:51
Reporter: Martin Mokrejs Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:5.6.27 OS:Linux
Assigned to: CPU Architecture:Any

[11 Feb 2016 11:20] Martin Mokrejs
Description:
After virtual hosting server failure 

   some gibberish omitted

InnoDB: End of page dump
2016-02-11 11:52:25 7f9d0cf6c740 InnoDB: uncompressed page, stored checksum in field1 2215800878, calculated checksums for field1: crc32 2024863159, innodb 27310463, none 3735928559, stored checksum in field2 537144060, calculated checksums for field2: crc32 2024863159, innodb 662309313, none 3735928559, page LSN 0 2035626805, low 4 bytes of LSN at page end 2036257994, page number (if stored to page already) 325, space id (if created with >= MySQL-4.1.1 and stored already) 0
InnoDB: Page may be an 'inode' page
InnoDB: Also the page in the doublewrite buffer is corrupt.
InnoDB: Cannot continue operation.
InnoDB: You can try to recover the database with the my.cnf
InnoDB: option:
InnoDB: innodb_force_recovery=6
2016-02-11 11:52:25 7f9d0cf6c740  InnoDB: Assertion failure in thread 140312504092480 in file buf0dblwr.cc line 559
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
10:52:25 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=16777216
read_buffer_size=262144
max_used_connections=0
max_threads=151
thread_count=0
connection_count=0
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 134280 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x31)[0x7f9d0c747751]
/usr/sbin/mysqld(handle_fatal_signal+0x3c9)[0x7f9d0c4ed949]
/lib64/libpthread.so.0(+0x10550)[0x7f9d0ad9e550]
/lib64/libc.so.6(gsignal+0x35)[0x7f9d0a3f83f5]
/lib64/libc.so.6(abort+0x17d)[0x7f9d0a3f989d]
/usr/sbin/mysqld(+0x861da4)[0x7f9d0c8fbda4]
/usr/sbin/mysqld(+0x7914b4)[0x7f9d0c82b4b4]
/usr/sbin/mysqld(+0x794422)[0x7f9d0c82e422]
/usr/sbin/mysqld(+0x7958c0)[0x7f9d0c82f8c0]
/usr/sbin/mysqld(+0x808e2a)[0x7f9d0c8a2e2a]
/usr/sbin/mysqld(+0x750635)[0x7f9d0c7ea635]
/usr/sbin/mysqld(_Z24ha_initialize_handlertonP13st_plugin_int+0x55)[0x7f9d0c41c175]
/usr/sbin/mysqld(+0x4d5426)[0x7f9d0c56f426]
/usr/sbin/mysqld(_Z11plugin_initPiPPci+0x643)[0x7f9d0c572e83]
/usr/sbin/mysqld(_Z11mysqld_mainiPPc+0x7f8)[0x7f9d0c414bb8]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x7f9d0a3e4a95]
/usr/sbin/mysqld(+0x36fa25)[0x7f9d0c409a25]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
I will upload the 800kB mysqld.err later

Suggested fix:
I also add my note to bug #71420 that the stacktrace should not advice to go immediately for a to destructive innodb_force_recovery value. It did not help in my case (stacktrace is same before and after innodb_force_recovery=6).
[11 Feb 2016 12:16] Martin Mokrejs
So provided this was the very first problem:

2016-02-11 01:57:38 1230 [Note] InnoDB: Using atomics to ref count buffer pool pages
2016-02-11 01:57:38 1230 [Note] InnoDB: The InnoDB memory heap is disabled
2016-02-11 01:57:38 1230 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-02-11 01:57:38 1230 [Note] InnoDB: Memory barrier is not used
2016-02-11 01:57:38 1230 [Note] InnoDB: Compressed tables use zlib 1.2.8
2016-02-11 01:57:38 1230 [Note] InnoDB: Using Linux native AIO
2016-02-11 01:57:38 1230 [Note] InnoDB: Not using CPU crc32 instructions
2016-02-11 01:57:38 1230 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2016-02-11 01:57:38 1230 [Note] InnoDB: Completed initialization of buffer pool
2016-02-11 01:57:40 1230 [Note] InnoDB: Restoring page 0 of tablespace 0
2016-02-11 01:57:40 1230 [Note] InnoDB: Writing 16384 bytes into file: ibdata1
2016-02-11 01:57:40 1230 [Note] InnoDB: Highest supported file format is Barracuda.
2016-02-11 01:57:40 1230 [Note] InnoDB: Log scan progressed past the checkpoint lsn 2036677253
2016-02-11 01:57:40 1230 [Note] InnoDB: Database was not shutdown normally!
2016-02-11 01:57:40 1230 [Note] InnoDB: Starting crash recovery.
2016-02-11 01:57:40 1230 [Note] InnoDB: Reading tablespace information from the .ibd files...
2016-02-11 01:57:43 7ff93d7bf740  InnoDB: Operating system error number 5 in a file operation.
InnoDB: Error number 5 means 'Input/output error'.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html
2016-02-11 01:57:43 1230 [ERROR] InnoDB: File ./d28330_wrdpres/wp_dailystat.ibd: 'stat' returned OS error 105.
2016-02-11 01:57:43 1230 [ERROR] InnoDB: os_file_readdir_next_file() returned -1 in directory ./d28330_wrdpres, crash recovery may have failed for some .ibd files!
2016-02-11 01:57:43 1230 [Note] InnoDB: Restoring possible half-written data pages 
2016-02-11 01:57:43 1230 [Note] InnoDB: from the doublewrite buffer...
InnoDB: Warning: database page corruption or a failed
InnoDB: file read of space 0 page 56.
InnoDB: Trying to recover it from the doublewrite buffer.
2016-02-11 01:57:45 1230 [Note] InnoDB: Recovered the page from the doublewrite buffer.
InnoDB: Warning: database page corruption or a failed
InnoDB: file read of space 0 page 325.
InnoDB: Trying to recover it from the doublewrite buffer.
InnoDB: Dump of the page:
2016-02-11 01:57:46 7ff93d7bf740 InnoDB: Page dump in ascii and hex (16384 bytes):
 len 16384; hex 9f42af2200000145000000000000000000000....

and my d28330_wrdpres/wp_dailystat.* files are gone due to the filesystem issue, I suspect mysql cannot overcome ibdata1 or mysqld-bin.* files referring to it. Is that the primary issue causing mysqld not to start? Does it make any sense?
[11 Feb 2016 12:36] Martin Mokrejs
-rw-rw----  1 mysql mysql       328 Feb 11 11:34 mysqld-bin.000028

root # mysqlbinlog mysqld-bin.000028 
/*!50530 SET @@SESSION.PSEUDO_SLAVE_MODE=1*/;
/*!40019 SET @@session.max_insert_delayed_threads=0*/;
/*!50003 SET @OLD_COMPLETION_TYPE=@@COMPLETION_TYPE,COMPLETION_TYPE=0*/;
DELIMITER /*!*/;
# at 4
#160211 11:32:36 server id 1  end_log_pos 120 CRC32 0xd152b018  Start: binlog v 4, server v 5.6.27-log created 160211 11:32:36 at startup
# Warning: this binlog is either in use or was not closed properly.
ROLLBACK/*!*/;
BINLOG '
RGO8Vg8BAAAAdAAAAHgAAAABAAQANS42LjI3LWxvZwAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAABEY7xWEzgNAAgAEgAEBAQEEgAAXAAEGggAAAAICAgCAAAACgoKGRkAARiw
UtE=
'/*!*/;
# at 120
#160211 11:34:13 server id 1  end_log_pos 224 CRC32 0x8b356df4  Query   thread_id=2     exec_time=0     error_code=0
use `d28330_wrdpres`/*!*/;
SET TIMESTAMP=1455186853/*!*/;
SET @@session.pseudo_thread_id=2/*!*/;
SET @@session.foreign_key_checks=1, @@session.sql_auto_is_null=0, @@session.unique_checks=1, @@session.autocommit=1/*!*/;
SET @@session.sql_mode=1073741824/*!*/;
SET @@session.auto_increment_increment=1, @@session.auto_increment_offset=1/*!*/;
/*!\C utf8mb4 *//*!*/;
SET @@session.character_set_client=45,@@session.collation_connection=45,@@session.collation_server=33/*!*/;
SET @@session.lc_time_names=0/*!*/;
SET @@session.collation_database=DEFAULT/*!*/;
OPTIMIZE TABLE wp_dailystat
/*!*/;
# at 224
#160211 11:34:16 server id 1  end_log_pos 328 CRC32 0x5814985e  Query   thread_id=6     exec_time=0     error_code=0
SET TIMESTAMP=1455186856/*!*/;
OPTIMIZE TABLE wp_dailystat
/*!*/;
DELIMITER ;
# End of log file
ROLLBACK /* added by mysqlbinlog */;
/*!50003 SET COMPLETION_TYPE=@OLD_COMPLETION_TYPE*/;
/*!50530 SET @@SESSION.PSEUDO_SLAVE_MODE=0*/;
root#
[20 May 2017 11:51] Shane Bester
I'd seriously advise to look into possible hardware failure or filesystem corruption on this system.  is there anything fishy going on, check dmesg and /var/log/messages* first.