Bug #8027 Cannot start by mysqld
Submitted: 20 Jan 2005 2:04 Modified: 4 Oct 2012 7:03
Reporter: Nick Fu Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:4.1.9 OS:Microsoft Windows (Win XP)
Assigned to: CPU Architecture:Any

[20 Jan 2005 2:04] Nick Fu
Description:
I have tried both "mysqld" and "mysqld --console" even after I uninstalled and reinstalled MySQL several times, but it just won't work, though starting by Window's service can be done.  See the log.

$ mysqld --console
InnoDB: Error: log file .\ib_logfile0 is of different size 0 10485760 bytes
InnoDB: than specified in the .cnf file 0 5242880 bytes!
050119 20:54:35 [ERROR] Can't init databases
050119 20:54:35

 [ERROR] Aborting

--------
Thanks!

How to repeat:
Install the .msi file, run the config, close MySQL, then go to DOS console and type mysqld --console...
[20 Jan 2005 7:22] Miguel Solorzano
I wasn't able to repeat this issue.

Additonal Info:

The error message means that the InnoDB files were created specifying
sizes that currently are different than the current ones in the
configuration file. If you have a fresh install and you can build them
again without to worry in loss data, then just delete the InnoDB files
and re-start the server, otherwise you need to specify the correct
values in your my.ini file.
[20 Jan 2005 15:20] Nick Fu
I instailed mysql-essential-4.1.9-win32.msi on my another machine that has Win2000 and the "mysqld --console" didn't work either.  It didn't work on 2 machines and I am sure something it wrong.  It was a fresh install and "mysqld"  just won't work.  In the config wizard, I cancelled the auto start from Win Services and I checked the Dos Command Line option to add the path to the win config.

Please check one more time. "mysqld" does not work on either XP or Win 2000.  And I have to use "net start mysql" to get it run and that command works though it is an extermal command.

Maybe the essential package got a lot of stuff missing.  The --debug option is not avalible either, though the menual instructed to use that when things go wrong.

Thanks!
[20 Jan 2005 15:20] Nick Fu
I instailed mysql-essential-4.1.9-win32.msi on my another machine that has Win2000 and the "mysqld --console" didn't work either.  It didn't work on 2 machines and I am sure something it wrong.  It was a fresh install and "mysqld"  just won't work.  In the config wizard, I cancelled the auto start from Win Services and I checked the Dos Command Line option to add the path to the win config.

Please check one more time. "mysqld" does not work on either XP or Win 2000.  And I have to use "net start mysql" to get it run and that command works though it is an extermal command.

Maybe the essential package got a lot of stuff missing.  The --debug option is not avalible either, though the menual instructed to use that when things go wrong.

Thanks!
[20 Jan 2005 15:29] Nick Fu
According the output there is a CNF file, but actually there is no in my MySQL directory and its sub-directories.  BTW, I didn't edit any of those config file after I ran the config wizard.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\nfu.XIAMEN>mysqld --console
InnoDB: Error: log file .\ib_logfile0 is of different size 0 10485760 bytes
InnoDB: than specified in the .cnf file 0 5242880 bytes!
050120 10:22:26 [ERROR] Can't init databases
050120 10:22:26 [ERROR] Aborting

050120 10:22:26 [Note] mysqld: Shutdown complete
[4 Oct 2012 7:03] Marko Mäkelä
Duplicate of Bug#13494