Bug #80100 Internal program error 2341 (failed ndbrequire) - Message to big in sendSignal
Submitted: 21 Jan 2016 14:38 Modified: 3 Mar 2016 12:34
Reporter: Salvador Salva Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Cluster: Disk Data Severity:S1 (Critical)
Version:mysql-cluster-gpl-7.4.8-linux-glibc2.5-x OS:Debian (3.16.0-4-amd64)
Assigned to: MySQL Verification Team CPU Architecture:Any
Tags: bug, nodes down

[21 Jan 2016 14:38] Salvador Salva
Description:
Hi,

We had a problem this morning and our cluster went down.
The cluster is composed by 2 management nodes, 2 mysql API servers and 2 datanodes (Rep factor 2)

Without doing anything special (before the crash I was doing a backup and using mysqldump) the 2 datanodes wend down with this error:

Status: Temporary error, restart node
Message: Internal program error (failed ndbrequire) (Internal error, programming error or missing error message, please report a bug)
Error: 2341
Error data: Message to big in sendSignal
Error object: 
Program: ndbd

How to repeat:
No clue how to reproduce it
[3 Mar 2016 12:33] MySQL Verification Team
Hi,

I'm not able to detect from the log how this happened nor I am able to reproduce this problem on my test setup. Did you have this error again after it shown for the first time?

all best
Bogdan Kecman

p.s.
I see you use disk data, note that few bugs wrt disk data are fixed since 7.4.8. Also 7.4.8 has a serious degradation of restart performance bug that is fixed in 7.4.10. I suggest you upgrade to 7.4.10 at earliest convenience.