Bug #79767 workbench packages are no listed by dnf
Submitted: 24 Dec 2015 1:04 Modified: 26 Dec 2015 16:52
Reporter: pat worth Email Updates:
Status: Closed Impact on me:
Category:MySQL Package Repos Severity:S3 (Non-critical)
Version: OS:Fedora (4.2.8-200.fc22.i686 )
Assigned to: CPU Architecture:Any

[24 Dec 2015 1:04] pat worth
I cannot install mysql-workbench-community via dnf on Fedora 22 because it does not show the workbench package even though the package is in the repo. I see the other utility packages but workbench is not listed. I have tried to locally install the .rpm but saw a bunch of dependency failures that do not make sense.

All other packages install as expected.

[root@localhost ~]# uname -a
Linux localhost.localdomain 4.2.8-200.fc22.i686 #1 SMP Tue Dec 15 17:29:29 UTC 2015 i686 i686 i386 GNU/Linux

[root@localhost ~]# dnf update
Last metadata expiration check performed 0:19:24 ago on Wed Dec 23 19:40:15 2015.
Dependencies resolved.
Nothing to do.

[root@localhost ~]# cat /etc/yum.repos.d/mysql-community.repo 
name=MySQL Connectors Community

name=MySQL Tools Community

# Enable to use MySQL 5.6
name=MySQL 5.6 Community Server

name=MySQL 5.7 Community Server

[root@localhost ~]# dnf repository-packages mysql-tools-community list
Last metadata expiration check performed 0:00:24 ago on Wed Dec 23 19:40:15 2015.
Available Packages
mysql-community-release.noarch                                    fc22-5                                           mysql-tools-community
mysql-utilities.noarch                                            1.5.6-1.fc22                                     mysql-tools-community
mysql-utilities-extra.noarch                                      1.5.6-1.fc22                                     mysql-tools-community

I have workbench installed successfully on a slightly less up-to-date fedora 22 install. 

This is running on an older Dell Inspiron laptop, but I have not had any installation issues of any software.

How to repeat:
[root@localhost ~]# dnf install mysql-workbench-community
Last metadata expiration check performed 0:24:22 ago on Wed Dec 23 19:40:15 2015.
No package mysql-workbench-community available.
Error: Unable to find a match
[24 Dec 2015 9:07] Terje Røsten
Hi, thanks for your report!

I am not able reproduce from my side. 

Can you try to force metadata update:

$ dnf --refresh install mysql-workbench-community
[24 Dec 2015 21:17] pat worth
Command line output of local rpm install attempt

Attachment: issue.txt (text/plain), 6.89 KiB.

[24 Dec 2015 21:18] pat worth
Thanks for the response. I had done a dnf clean all as part of my original troubleshooting.

I just did as you suggested with the same result:

[root@localhost worthp]# dnf --refresh install mysql-workbench-community
MySQL 5.6 Community Server                                                             1.5 MB/s | 279 kB     00:00
google-chrome                                                                           35 kB/s | 3.6 kB     00:00
MySQL Tools Community                                                                   56 kB/s | 4.7 kB     00:00
MySQL Connectors Community                                                              73 kB/s | 8.5 kB     00:00
Last metadata expiration check performed 0:00:00 ago on Thu Dec 24 16:01:15 2015.
No package mysql-workbench-community available. 
Error: Unable to find a match.

I am not an expert on dnf/yum, but it is confusing to me why some of the packages in the repo are accessible but workbench is not. What might cause that? As I mentioned in my original post, I tried a local install of the package. This is the result - maybe it will show a hint of the underlying issue (dependency fails that I do not believe should fail).

I have attached the command line output of that exercise.

The first dependency error seems to be refuted by this:

[root@localhost Downloads]# ll /lib/libGL.so.1
lrwxrwxrwx. 1 root root 14 Oct  8 10:38 /lib/libGL.so.1 -> libGL.so.1.2.0

Maybe the symbolic link is causing an issue??? To be clear, this is a vanilla F22 install. I have not done anything outside of initial install and dnf.

Thanks again.
[25 Dec 2015 10:38] Terje Røsten
Hi again,

seems like some sort of cache issue at download mirrors.
We will have a look.

Thanks for your feedback!
[26 Dec 2015 16:03] pat worth
dmesg output

Attachment: dmesg.txt (text/plain), 60.89 KiB.

[26 Dec 2015 16:29] pat worth
I noticed that on boot I am seeing a few cpu warnings. I did some more poking around and I think there may some indicators that the cpu is 32 bit. I am not an expert in the architecture identification, but I am thinking that is my issue.

Clearly fedora install recognizes arch as 64 bit:

[worthp@localhost ~]$ uname -a
Linux localhost.localdomain 4.2.8-200.fc22.i686 #1 SMP Tue Dec 15 17:29:29 UTC 2015 i686 i686 i386 GNU/Linux

However, when checking into the chip it seems it is 32 bit, http://ark.intel.com/products/27231

"Memory Specifications
Physical Address Extensions	32-bit"

However, it seems i686 binaries are running on this arch.

root@localhost worthp]# dnf -d 10 list mysql-*
timer: config: 18 ms
cachedir: /var/cache/dnf
Loaded plugins: builddep, config-manager, reposync, migrate, needs-restarting, generate_completion_cache, copr, playground, protected_packages, download, Query, debuginfo-install, noroot
DNF version: 1.1.4
Command: dnf -d 10 list mysql-* 
Installroot: /
Releasever: 22
Base command: list
Extra commands: [u'mysql-*']
repo: using cache for: fedora
not found deltainfo for: Fedora 22 - i386
not found updateinfo for: Fedora 22 - i386
repo: using cache for: mysql56-community
not found deltainfo for: MySQL 5.6 Community Server
not found updateinfo for: MySQL 5.6 Community Server
repo: using cache for: google-chrome
not found deltainfo for: google-chrome
not found updateinfo for: google-chrome
repo: using cache for: mysql-tools-community
not found deltainfo for: MySQL Tools Community
not found updateinfo for: MySQL Tools Community
repo: using cache for: updates
repo: using cache for: mysql-connectors-community
not found deltainfo for: MySQL Connectors Community
not found updateinfo for: MySQL Connectors Community
timer: sack setup: 1088 ms
fedora: using metadata from Sat May 23 05:54:01 2015.
mysql56-community: using metadata from Mon Dec  7 10:25:00 2015.
google-chrome: using metadata from Wed Dec 16 18:24:49 2015.
mysql-tools-community: using metadata from Tue Dec 15 02:34:34 2015.
updates: using metadata from Mon Dec 21 19:54:03 2015.
mysql-connectors-community: using metadata from Fri Sep 25 13:24:02 2015.
Last metadata expiration check performed 0:33:33 ago on Sat Dec 26 10:52:54 2015.
Installed Packages
mysql-community-client.i686                                      5.6.28-1.fc22                              @mysql56-community        
mysql-community-common.i686                                      5.6.28-1.fc22                              @mysql56-community        
mysql-community-libs.i686                                        5.6.28-1.fc22                              @mysql56-community        
Available Packages
MySQL-python.i686                                                1.3.6-3.fc22                               updates                   
MySQL-python-debug.i686                                          1.3.6-3.fc22                               updates                   
MySQL-python3.i686                                               1.3.6-3.fc22                               updates                   
MySQL-python3-debug.i686                                         1.3.6-3.fc22                               updates                   
MySQL-zrm.noarch                                                 3.0-7.fc22                                 fedora                    
mysql-community-bench.i686                                       5.6.28-1.fc22                              mysql56-community         
mysql-community-devel.i686                                       5.6.28-1.fc22                              mysql56-community         
mysql-community-embedded.i686                                    5.6.28-1.fc22                              mysql56-community         
mysql-community-embedded-devel.i686                              5.6.28-1.fc22                              mysql56-community         
mysql-community-release.noarch                                   fc22-5                                     mysql56-community         
mysql-community-server.i686                                      5.6.28-1.fc22                              mysql56-community         
mysql-community-test.i686                                        5.6.28-1.fc22                              mysql56-community         
mysql-connector-java.noarch                                      1:5.1.28-6.fc22                            updates                   
mysql-connector-odbc.i686                                        5.3.4-3.fc22                               updates                   
mysql-connector-odbc-debuginfo.i686                              5.3.4-1.fc22                               mysql-connectors-community
mysql-connector-odbc-setup.i686                                  5.3.4-1.fc22                               mysql-connectors-community
mysql-connector-python.noarch                                    2.0.4-1.fc22                               mysql-connectors-community
mysql-connector-python.i686                                      2.1.3-1.fc22                               mysql-connectors-community
mysql-connector-python-cext.i686                                 2.1.3-1.fc22                               mysql-connectors-community
mysql-connector-python-debuginfo.i686                            2.1.3-1.fc22                               mysql-connectors-community
mysql-connector-python3.noarch                                   2.0.4-1.fc22                               mysql-connectors-community
mysql-connector-python3.i686                                     2.1.3-1.fc22                               mysql-connectors-community
mysql-connector-python3-cext.i686                                2.1.3-1.fc22                               mysql-connectors-community
mysql-mmm.noarch                                                 2.2.1-12.fc21                              fedora                    
mysql-mmm-agent.noarch                                           2.2.1-12.fc21                              fedora                    
mysql-mmm-monitor.noarch                                         2.2.1-12.fc21                              fedora                    
mysql-mmm-tools.noarch                                           2.2.1-12.fc21                              fedora                    
mysql-proxy.i686                                                 0.8.5-1.fc22                               fedora                    
mysql-proxy-devel.i686                                           0.8.5-1.fc22                               fedora                    
mysql-utilities.noarch                                           1.5.6-1.fc22                               mysql-tools-community     
mysql-utilities-extra.noarch                                     1.5.6-1.fc22                               mysql-tools-community     
Cleaning up.

And as another example,
[root@localhost worthp]# dnf info gimp
Last metadata expiration check performed 0:35:49 ago on Sat Dec 26 10:52:54 2015.
Installed Packages
Name        : gimp
Arch        : i686
Epoch       : 2
Version     : 2.8.16
Release     : 1.fc22
Size        : 63 M
Repo        : @System
From repo   : updates
Summary     : GNU Image Manipulation Program
URL         : http://www.gimp.org/
License     : GPLv3+ and GPLv3
Description : GIMP (GNU Image Manipulation Program) is a powerful image composition and
            : editing program, which can be extremely useful for creating logos and other
            : graphics for webpages. GIMP has many of the tools and filters you would expect
            : to find in similar commercial offerings, and some interesting extras as well.
            : GIMP provides a large image manipulation toolbox, including channel operations
            : and layers, effects, sub-pixel imaging and anti-aliasing, and conversions, all
            : with multi-level undo.

This is very confusing.

Thanks again for any direction.
[26 Dec 2015 16:31] pat worth
reducing the severity to non-critical since it seems to be related to old hardware. it is still confusing though.
[26 Dec 2015 16:52] pat worth
Ok. So after some more research, it seems this chipset is 32 bit. I have checked a few of the running binaries and even though the packages are showing 686 arch, the binaries are 32 bit ELF

[root@localhost Software]# file /usr/bin/gcc
/usr/bin/gcc: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=cfd73837cdc26eebc43669635b68065a952ddb26, stripped
[root@localhost Software]# dnf list gcc
Last metadata expiration check performed 0:54:10 ago on Sat Dec 26 10:52:54 2015.
Installed Packages

and more peculiar (to me):

[root@localhost Software]# gcc -v
Using built-in specs.
Target: i686-redhat-linux
Configured with: ../configure --enable-bootstrap --enable-languages=c,c++,objc,obj-c++,fortran,ada,go,lto --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-shared --enable-threads=posix --enable-checking=release --enable-multilib --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-plugin --enable-initfini-array --disable-libgcj --with-default-libstdcxx-abi=gcc4-compatible --with-isl --enable-libmpx --enable-gnu-indirect-function --with-tune=generic --with-arch=i686 --build=i686-redhat-linux
Thread model: posix
gcc version 5.3.1 20151207 (Red Hat 5.3.1-2) (GCC) 

However, by all detail accounts this is a 32 bit dual core. Maybe there is some compatibility magic.

In any case, I don't see this as an issue with mysql packaging but rather this arch is an anomaly. Perhaps I will try to build from source

I am closing this out so not to waste anyone's time on an outlier.