Bug #7954 No Statuses listed - can't close issues
Submitted: 17 Jan 2005 12:09 Modified: 19 Jan 2005 21:24
Reporter: Mr. Venom Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Eventum Severity:S3 (Non-critical)
Version:04 Jan 2005, Version 1.4 OS:-
Assigned to: Bugs System CPU Architecture:Any

[17 Jan 2005 12:09] Mr. Venom
Description:
I may be wrong, but it seems that in include/class.status.php
function getClosedAssocList ...
the line
                    prs_prj_id=$prj_id AND
shoud be ommitted / commented out, since the logic is to select any statuses that have the "closed" attribute

How to repeat:
create an issue, post some replies, try to close it

Suggested fix:
include/class.status.php, around line 735
    function getClosedAssocList($prj_id)
    {
        $stmt = "SELECT
                    sta_id,
                    sta_title
                 FROM
                    " . APP_DEFAULT_DB . "." . APP_TABLE_PREFIX . "status,
                    " . APP_DEFAULT_DB . "." . APP_TABLE_PREFIX . "project_status
                 WHERE
                    -- prs_prj_id=$prj_id AND
                    prs_sta_id=sta_id AND
                    sta_is_closed=1
                 ORDER BY
                    sta_rank ASC";
....
[19 Jan 2005 21:24] Joao Prado Maia
No, the logic is to return the list of closed-context statuses for that given project. Since the list of statuses is dynamic at a project level, this is needed.

Thanks for the report, but this is not a bug.

--Joao