Bug #79419 semisynchronous replication support in MySQL Fabric
Submitted: 26 Nov 2015 8:10 Modified: 28 Nov 2015 9:05
Reporter: Ted Wennmark Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Fabric Severity:S4 (Feature request)
Version:1.6 OS:Any
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D5 (Feature request)

[26 Nov 2015 8:10] Ted Wennmark
Description:
I'm missing better help/support for setting up semi-synchronous replication support using MySQL Fabric. I am aware you can do this manually but then fabric will not be aware of this and that might be useful information to have for lossless failover using MySQL 5.7.

What's missing is;
1) MySQL Fabric should have option for setting up server using SEMISYNC replication when adding server to a group.
2) When using SEMISYNC to ensure loss-less fail-over within one data-centre people want fabric to promote/elect the server using SEMISYNC replication at fail-over/switch-over and not the SECONDARY in data-center 2 using ASYNC replication, see below for more details.

     Data center 1            Data center 2
 PRIMARY ---> SECONDARY
         ---------------------> SECONDARY

The 2 servers in DC one uses SEMI-SYNC replication, to not loose data at fail-over.
Replication between DC should be normal ASYNC replication.

How to repeat:
This is a FR not a bug

Suggested fix:
Implement the above to better support semi-synchronous replication.
[28 Nov 2015 9:05] Umesh Shastry
Hello Ted,

Thank you for the reasonable feature request!

Thanks,
Umesh
[6 Jul 2017 19:20] Bugs System
Status updated to 'Won't fix' (Fabric is now covered under Oracle Lifetime Sustaining Support)