Bug #79344 RPM build fails for MySQL Utilities
Submitted: 19 Nov 2015 17:43 Modified: 14 Dec 2016 16:52
Reporter: monty solomon Email Updates:
Status: Verified Impact on me:
Category:MySQL Utilities Severity:S2 (Serious)
Version:1.6.4 OS:CentOS (6)
Assigned to: CPU Architecture:Any

[19 Nov 2015 17:43] monty solomon
Running python setup.py bdist_rpm in the source directory fails

How to repeat:
Download the source file mysql-utilities-1.5.6.zip

% unzip mysql-utilities-1.5.6.zip
% cd mysql-utilities-1.5.6

% python setup.py bdist_rpm


Conflicts: mysql-connector-python = 2.1.0 mysql-connector-python = 2.1.1 mysql-utilities-commercial
Obsoletes: mysql-utilities <= 1.5.6 mysql-utilities-commercial <= 1.5.6
Checking for unpackaged file(s): /usr/lib/rpm/check-files /usr/share/hubspot/tmp/new/mysql-utilities-1.5.6/build/bdist.linux-x86_64/rpm/BUILDROOT/mysql-utilities-1.5.6-1.el6.x86_64
error: Installed (but unpackaged) file(s) found:

RPM build errors:
    Installed (but unpackaged) file(s) found:
error: command 'rpmbuild' failed with exit status 1
[24 Nov 2015 21:15] MySQL Verification Team
Thank you for the bug report. Reading the manual:


I wasn't able to find where is the instructions to build rmp package, could you please point me it. Thanks.

shell> unzip mysql-utilities-1.5.6.zip
shell> cd mysql-utilities-1.5.6
shell> python ./setup.py build
shell> sudo python ./setup.py install
[26 Nov 2015 3:48] monty solomon
See the python documentation at https://docs.python.org/2.6/distutils/builtdist.html

If there is a different method to build the RPM file for MySQL Utilities then it should be documented appropriately.
[27 Nov 2015 13:01] MySQL Verification Team
That isn't our Manual the only instructions I found in our documentation is what I mentioned you, what you can ask is a feature request.
[28 Dec 2015 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 Jan 2016 4:10] monty solomon
The error message and build failure are caused by these two lines in the support/RPM/mysql_utilities_src.spec file

   %doc %{_docdir}/%{name}-%{version}/README_*.txt
   %doc %{_docdir}/%{name}-%{version}/CHANGES_*.txt

The underscores prevent it from matching the installed files


Removing the underscores eliminates the error

   %doc %{_docdir}/%{name}-%{version}/README*.txt
   %doc %{_docdir}/%{name}-%{version}/CHANGES*.txt
[19 Oct 2016 11:39] Chiranjeevi Battula
Hello monty solomon,

Thank you for the bug feedback.
I tried with latest version of MySQL Utilities 1.6.4 version as well and it worked without any issues.
Probably this is fixed in latest version, please feel free to reopen this bug report if you encounter this issue again.

[19 Oct 2016 21:07] monty solomon
+ cd mysql-utilities-1.6.4
+ export LANG
+ unset DISPLAY
+ python setup.py build
Traceback (most recent call last):
  File "setup.py", line 36, in <module>
    from info import META_INFO, INSTALL
ImportError: No module named info
error: Bad exit status from /var/tmp/rpm-tmp.BrF6bg (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.BrF6bg (%build)
error: command 'rpmbuild' failed with exit status 1
[19 Oct 2016 21:10] monty solomon
The same problem was reported in the github project.


[19 Oct 2016 21:59] monty solomon
The source distribution files seem to be built incorrectly.

I can run ⁠⁠⁠⁠python setup.py bdist_rpm⁠⁠⁠⁠ from the git tree but not from the official tar.gz or zip files.
[19 Oct 2016 22:05] monty solomon
The git tree contains files that are not included in either the tar or zip file distributions:

Only in mysql-utilities-master: check.py
Only in mysql-utilities-master: freeze.py
Only in mysql-utilities-master: MANIFEST.in
Only in mysql-utilities-master: mysql-test
Only in mysql-utilities-master: package.py
Only in mysql-utilities-master: support
Only in mysql-utilities-master/unit_tests: sample-general.log
Only in mysql-utilities-master/unit_tests: sample-slow.log
[14 Dec 2016 16:52] Jose Israel Gomez Delgado
Bug is reproducible in OLE 6.