Bug #79264 MySQL Installer Community Edition hangs on scheduled task creation
Submitted: 13 Nov 2015 9:57 Modified: 27 Jul 2016 13:02
Reporter: Daniele Mancino Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:1.4.16 OS:Microsoft Windows (Windows 10 Home Edition)
Assigned to: CPU Architecture:Any
Tags: Catalog Update, installation, Scheduled Task

[13 Nov 2015 9:57] Daniele Mancino
Description:
I'm guessing this is related to http://bugs.mysql.com/bug.php?id=78193 as I had the same exact problem when running a fresh install (as per description and screenshot of that bug). I resolved it by finding out that there were more than one (three) Msiexec tasks running and force closing one of them, this made the installation not hang anymore and complete.
But then the installer hangs at the "Automatic Catalog Update" option dialog. Every time I tick the "Should MySQL Installer periodically update it's catalog each day?" checkbox, it just hangs forever and does not create the scheduled task. All I found out is that closing the schtasks.exe task running makes the Installer stop hanging, by just closing the Options dialog with no changes.

How to repeat:
Install MySQL Installer 

Suggested fix:
Probably related to #78193
[13 Nov 2015 10:03] Daniele Mancino
Options dialog hanging

Attachment: Options dialog hanging.jpg (image/jpeg, text), 30.60 KiB.

[13 Nov 2015 10:03] Daniele Mancino
Task running but hanging

Attachment: Task running but hanging.jpg (image/jpeg, text), 127.96 KiB.

[13 Nov 2015 12:33] Miguel Solorzano
Thank you for the bug report. Indeed looks related to http://bugs.mysql.com/bug.php?id=78193, please re-open this bug report with your comment when you will able to check 1.4.12 when available. Thanks.
[14 Dec 2015 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[14 Dec 2015 2:29] Daniele Mancino
Still same problem as of 1.4.13.
[23 Dec 2015 12:15] Chiranjeevi Battula
Hello Daniele Mancino,

Thank you for your feedback.
I tried to reproduce the issue at my end using MySQL Installer 1.4.13 but not seeing any issue in scheduler.

Thanks,
Chiranjeevi.
[27 Jul 2016 13:02] Daniele Mancino
If this can be of any help tracking down the issue (which I still have as of 1.4.16): I had a very similar problem when updating Java Runtime Environment 64bit to latest update (102). When clicking on the offline installer nothing happened, and I found out there were two instances of the installer .exe in task manager. Force closing one made the other one just keep hanging, while force closing the other one made both executables close. In this case, I ended up uninstalling both 32 and 64 bit Java, and installing them (since I continued having the problem) with Ninite (the 32bit JRE) and a with a CLI install with a .msi I found in my AppData folder (the 64bit JRE).

My knowledge is very limited but to me it *looks like* something related to Windows ownership conflicts, or 32/64bit conflicts. I have dozens of programs installed which I regularly and seamlessly update and MySQL Installer and JRE are the only ones with this problem.