Bug #79195 can't save a model
Submitted: 9 Nov 2015 23:12 Modified: 11 Nov 2015 9:13
Reporter: Shlomo Belleli Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.4 OS:Microsoft Windows (Microsoft Windows 7 Enterprise Service Pack 1)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Nov 2015 23:12] Shlomo Belleli
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\shlomob\AppData\Roaming\MySQL\Workbench\log\wb.log]

01:07:08 [ERR][      Workbench]: Console redirection failed.
01:07:08 [INF][      WBContext]: Parsing application arguments.
01:07:08 [INF][      WBContext]:     C:\Program Files\MySQL\MySQL Workbench 6.2 CE\MySQLWorkbench.exe
01:07:08 [INF][      Workbench]: Starting up Workbench
01:07:08 [INF][      Workbench]: Current environment:
	Command line: "C:\Program Files\MySQL\MySQL Workbench 6.2 CE\MySQLWorkbench.exe" 
	CurrentDirectory: C:\Program Files\MySQL\MySQL Workbench 6.2 CE
	HasShutdownStarted: False
	OSVersion: Microsoft Windows NT 6.1.7601 Service Pack 1
	SystemDirectory: C:\WINDOWS\system32
	TickCount: 199728267
	UserInteractive: True
	Version: 4.0.30319.18444
	WorkingSet: 33849344
01:07:08 [INF][      Workbench]: Environment variables:
	SystemDrive = C:
	ProgramFiles(x86) = C:\Program Files (x86)
	USERDNSDOMAIN = TALDOR.CORP
	ProgramW6432 = C:\Program Files
	PROCESSOR_IDENTIFIER = Intel64 Family 6 Model 37 Stepping 5, GenuineIntel
	TMP = C:\Users\shlomob\AppData\Local\Temp
	PROCESSOR_ARCHITECTURE = AMD64
	PATHEXT = .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
	PROCESSOR_REVISION = 2505
	TEMP = C:\Users\shlomob\AppData\Local\Temp
	USERPROFILE = C:\Users\shlomob
	LOGONSERVER = \\TDC1
	USERNAME = shlomob
	SystemRoot = C:\WINDOWS
	__COMPAT_LAYER = DisableUserCallbackException
	FP_NO_HOST_CHECK = NO
	DART_SDK = C:\Program Files\Dart\dart-sdk
	CommonProgramFiles = C:\Program Files\Common Files
	UATDATA = C:\WINDOWS\CCM\UATData\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77
	ProgramData = C:\ProgramData
	windows_tracing_logfile = C:\BVTBin\Tests\installpackage\csilogfile.log
	HOMEPATH = \Users\shlomob
	COMPUTERNAME = L002437
	ALLUSERSPROFILE = C:\ProgramData
	CommonProgramW6432 = C:\Program Files\Common Files
	windows_tracing_flags = 3
	SESSIONNAME = Console
	CommonProgramFiles(x86) = C:\Program Files (x86)\Common Files
	HOMEDRIVE = C:
	windir = C:\WINDOWS
	NUMBER_OF_PROCESSORS = 4
	OS = Windows_NT
	ProgramFiles = C:\Program Files
	ComSpec = C:\WINDOWS\system32\cmd.exe
	JAVA_HOME = C:\program files\java\jdk1.8.0_51
	PSModulePath = C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\
	APPDATA = C:\Users\shlomob\AppData\Roaming
	USERDOMAIN = TALDOR
	PROCESSOR_LEVEL = 6
	LOCALAPPDATA = C:\Users\shlomob\AppData\Local
	TVT = C:\Program Files (x86)\Lenovo
	Path = C:\ProgramData\Oracle\Java\javapath;C:\program files\java\jdk1.8.0_51;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\ThinkPad\Bluetooth Software\;C:\Program Files\ThinkPad\Bluetooth Software\syswow64;C:\Program Files (x86)\ImageConverter Plus;C:\Program Files (x86)\MySQL\MySQL Utilities\;C:\Program Files (x86)\MySQL\MySQL Utilities\Doctrine extensions for PHP\;C:\program files\java\jdk1.8.0_51\bin;;C:\Program Files\Dart\dart-sdk\bin
	PUBLIC = C:\Users\Public
01:07:08 [INF][      Workbench]: Current version given by meta info is: 6.3.4
01:07:08 [INF][      Workbench]: Setting PATH to: C:\WINDOWS\system32;C:\ProgramData\Oracle\Java\javapath;C:\program files\java\jdk1.8.0_51;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\ThinkPad\Bluetooth Software\;C:\Program Files\ThinkPad\Bluetooth Software\syswow64;C:\Program Files (x86)\ImageConverter Plus;C:\Program Files (x86)\MySQL\MySQL Utilities\;C:\Program Files (x86)\MySQL\MySQL Utilities\Doctrine extensions for PHP\;C:\program files\java\jdk1.8.0_51\bin;;C:\Program Files\Dart\dart-sdk\bin
01:07:08 [INF][ mforms managed]: Initializing mforms wrapper
01:07:09 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: C:\Program Files\MySQL\MySQL Workbench 6.2 CE
	plugin path: C:\Program Files\MySQL\MySQL Workbench 6.2 CE
	struct path: 
	module path: C:\Program Files\MySQL\MySQL Workbench 6.2 CE/modules
	library path: C:\Program Files\MySQL\MySQL Workbench 6.2 CE
	user data dir: C:\Users\shlomob\AppData\Roaming\MySQL\Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
01:07:09 [INF][      WBContext]: WbContext::init
01:07:09 [INF][            grt]: Scanning module directory C:\Users\shlomob\AppData\Roaming\MySQL\Workbench\modules.	
01:07:09 [INF][            grt]: Scanning module directory ..	
01:07:09 [INF][            grt]: Scanning module directory C:\Program Files\MySQL\MySQL Workbench 6.2 CE/modules.	
01:07:09 [INF][            WBA]: Looking for extension modules for WBA...
01:07:09 [INF][            WBA]: 0 extension modules found
01:07:09 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.2 CE\data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
01:07:09 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.2 CE\data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
01:07:09 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.2 CE\data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
01:07:09 [INF][            grt]: Scanning module directory C:\Program Files\MySQL\MySQL Workbench 6.2 CE.	
01:07:09 [WRN][            grt]: C:\Users\shlomob\AppData\Roaming\MySQL\Workbench\connections.xml:18: link '{6F942516-A701-461E-8ABF-7372B7B82C0C}' <object GrtObject> key=owner could not be resolved
01:07:09 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 6.3.4  revision 0 build 828 (64 bit)
	Configuration Directory: C:\Users\shlomob\AppData\Roaming\MySQL\Workbench
	Data Directory: C:\Program Files\MySQL\MySQL Workbench 6.2 CE
	Cairo Version: 1.10.2
	OS: Microsoft Windows 7 Enterprise Service Pack 1
	CPU: 4x Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz, 3.8 GiB RAM
	Active video adapter Intel(R) HD Graphics
	Installed video RAM: 1721 MB
	Current video mode: 1680 x 1050 x 4294967296 colors
	Used bit depth: 32
	Driver version: 8.15.10.2993
	Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
	Current user language: Hebrew (Israel)

01:07:09 [INF][      Workbench]: UI is up
01:07:10 [INF][      Workbench]: Running the application
01:07:15 [INF][ Canvas backend]: Found OpenGL version for this view: 2.1.0 - Build 8.15.10.2993
01:07:25 [INF][ Canvas backend]: Found OpenGL version for this view: 2.1.0 - Build 8.15.10.2993

How to repeat:
When I try to save a Model I get an error 
I I am trying to save the "sakila" model it works fine when I am trying to save my own models, I get the error and the program fails.
these models worked fine in the past (two months ogo)
[9 Nov 2015 23:59] Shlomo Belleli
When I am tring to save a model to disk c: it's Ok
When I am tring to save to disk d: I got an error
[10 Nov 2015 0:37] Miguel Solorzano
Thank you for the bug report.

Current user language: Hebrew (Israel)

Is there in the path where you can't save Hebrew symbols?.

Thanks.
[11 Nov 2015 3:13] Shlomo Belleli
Hi 
An anwser to your question: Is there in the path where you can't save Hebrew symbols?.

Yes - I checked it again, and you are right this is the problem
when saving it to disk D without any hebrew symbols, it work fine.

Shlomo
[11 Nov 2015 9:13] Miguel Solorzano
Thank you for the feedback. Duplicate of bug http://bugs.mysql.com/bug.php?id=48057.