Bug #79164 Workbench doesn't retrieve changes once applied
Submitted: 6 Nov 2015 22:55 Modified: 7 Dec 2015 19:57
Reporter: Konstantinos Magarisiotis Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.3.5 OS:Microsoft Windows (Microsoft Windows 8.1)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[6 Nov 2015 22:55] Konstantinos Magarisiotis
Description:
Once you make some changes in a table (alter table) and you hit Apply, if you hit apply again the same changes remain in the 'Review Script Window' and are executed again.

If you try to close the window a message 'Do you want to save the changes appear'.
If you hit Apply, the script runs once again.

[188, 00:50:36] Apply changes to new_table: Preparing...
[188, 00:50:38] Applying changes to new_table...: 
[188, 00:50:38] : Changes applied to new_table
[188, 00:50:39] Apply changes to new_table: Changes applied
[189, 00:50:40] Apply changes to new_table: Preparing...
[189, 00:50:41] Applying changes to new_table...: 
[189, 00:50:41] : Changes applied to new_table
[189, 00:50:42] Apply changes to new_table: Changes applied

How to repeat:
Open the Workbench, alter a table and hit Apply. Then hit Apply once again.
[7 Nov 2015 11:59] MySQL Verification Team
Hello Konstantinos,

Thank you for the report.
Verified as described with 6.3.5 on Win7.

Thanks,
Umesh
[10 Nov 2015 9:01] Mike Lischke
Bug #79190 was marked as duplicate of this bug
[7 Dec 2015 19:57] Philip Olson
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 6.3.6 release, and here's the changelog entry:

Clicking Apply a second time while performing an Alter Table operation
would emit a "No Changes Detected" message, despite changes being present.

Thank you for the bug report.