Bug #79094 "Error while loading image" on startup, and then doesn't open connection
Submitted: 3 Nov 2015 12:20 Modified: 4 Nov 2015 20:27
Reporter: Lee Butler Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.5 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any
Tags: crashing, no connection, opening, workbench

[3 Nov 2015 12:20] Lee Butler
Description:
12:11:21 [ERR][      Workbench]: Console redirection failed.
12:11:21 [INF][      WBContext]: Parsing application arguments.
12:11:21 [INF][      WBContext]:     C:\Program Files\MySQL\MySQL Workbench 6.3 CE\MySQLWorkbench.exe
12:11:21 [INF][      Workbench]: Starting up Workbench
12:11:21 [INF][      Workbench]: Current environment:
	Command line: "C:\Program Files\MySQL\MySQL Workbench 6.3 CE\MySQLWorkbench.exe" 
	CurrentDirectory: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	HasShutdownStarted: False
	OSVersion: Microsoft Windows NT 6.2.9200.0
	SystemDirectory: C:\WINDOWS\system32
	TickCount: 6144359
	UserInteractive: True
	Version: 4.0.30319.42000
	WorkingSet: 32960512
12:11:21 [INF][      Workbench]: Environment variables:
	COMPUTERNAME = LEE-PC
	USERPROFILE = C:\Users\Lee
	HOMEPATH = \Users\Lee
	LOCALAPPDATA = C:\Users\Lee\AppData\Local
	PSModulePath = C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\
	PROCESSOR_ARCHITECTURE = AMD64
	Path = C:\Program Files (x86)\Common Files\TEC-IT\TBarCode\10.2\;C:\Program Files\Common Files\TEC-IT\TBarCode\10.2\;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\AMD\ATI.ACE\Core-Static;C:\WINDOWS\system32\config\systemprofile\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin;C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin;C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit\;C:\Program Files (x86)\MySQL\MySQL Fabric 1.5 & MySQL Utilities 1.5\;C:\Program Files (x86)\MySQL\MySQL Fabric 1.5 & MySQL Utilities 1.5\Doctrine extensions for PHP\
	CommonProgramFiles(x86) = C:\Program Files (x86)\Common Files
	ProgramFiles(x86) = C:\Program Files (x86)
	PROCESSOR_LEVEL = 6
	windows_tracing_flags = 3
	LOGONSERVER = \\LEE-PC
	PATHEXT = .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
	HOMEDRIVE = C:
	SystemRoot = C:\WINDOWS
	SESSIONNAME = Console
	ALLUSERSPROFILE = C:\ProgramData
	PUBLIC = C:\Users\Public
	FP_NO_HOST_CHECK = NO
	APPDATA = C:\Users\Lee\AppData\Roaming
	PROCESSOR_REVISION = 3c03
	USERNAME = Lee
	CommonProgramW6432 = C:\Program Files\Common Files
	TEMP = C:\Users\Lee\AppData\Local\Temp
	CommonProgramFiles = C:\Program Files\Common Files
	OS = Windows_NT
	USERDOMAIN_ROAMINGPROFILE = Lee-PC
	PROCESSOR_IDENTIFIER = Intel64 Family 6 Model 60 Stepping 3, GenuineIntel
	ComSpec = C:\WINDOWS\system32\cmd.exe
	SystemDrive = C:
	FPS_BROWSER_USER_PROFILE_STRING = Default
	ProgramFiles = C:\Program Files
	NUMBER_OF_PROCESSORS = 4
	windows_tracing_logfile = C:\BVTBin\Tests\installpackage\csilogfile.log
	FPS_BROWSER_APP_PROFILE_STRING = Internet Explorer
	VS140COMNTOOLS = C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\
	TMP = C:\Users\Lee\AppData\Local\Temp
	ProgramData = C:\ProgramData
	ProgramW6432 = C:\Program Files
	windir = C:\WINDOWS
	USERDOMAIN = Lee-PC
12:11:21 [INF][      Workbench]: Current version given by meta info is: 6.3.5
12:11:21 [INF][      Workbench]: Setting PATH to: C:\WINDOWS\system32;C:\Program Files (x86)\Common Files\TEC-IT\TBarCode\10.2\;C:\Program Files\Common Files\TEC-IT\TBarCode\10.2\;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\AMD\ATI.ACE\Core-Static;C:\WINDOWS\system32\config\systemprofile\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin;C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin;C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit\;C:\Program Files (x86)\MySQL\MySQL Fabric 1.5 & MySQL Utilities 1.5\;C:\Program Files (x86)\MySQL\MySQL Fabric 1.5 & MySQL Utilities 1.5\Doctrine extensions for PHP\
12:11:21 [INF][ mforms managed]: Initializing mforms wrapper
12:11:21 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	plugin path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	struct path: 
	module path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE/modules
	library path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	user data dir: C:\Users\Lee\AppData\Roaming\MySQL\Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
12:11:21 [INF][      WBContext]: WbContext::init
12:11:21 [INF][            grt]: Scanning module directory C:\Users\Lee\AppData\Roaming\MySQL\Workbench\modules.	
12:11:21 [INF][            grt]: Scanning module directory ..	
12:11:21 [INF][            grt]: Scanning module directory C:\Program Files\MySQL\MySQL Workbench 6.3 CE/modules.	
12:11:21 [INF][            WBA]: Looking for extension modules for WBA...
12:11:21 [INF][            WBA]: 0 extension modules found
12:11:21 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
12:11:21 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
12:11:21 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
12:11:21 [INF][            grt]: Scanning module directory C:\Program Files\MySQL\MySQL Workbench 6.3 CE.	
12:11:21 [WRN][            grt]: C:\Users\Lee\AppData\Roaming\MySQL\Workbench\connections.xml:25: link '{49F2CA16-176D-43D1-B8AE-BD83BED070EC}' <object GrtObject> key=owner could not be resolved
12:11:21 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 6.3.5 CE build 201 (64 bit)
	Configuration Directory: C:\Users\Lee\AppData\Roaming\MySQL\Workbench
	Data Directory: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	Cairo Version: 1.10.2
	OS: Microsoft Windows 10 Pro
	CPU: 4x Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz, 7.9 GiB RAM
	Active video adapter Intel(R) HD Graphics 4600
	Installed video RAM: 1024 MB
	Current video mode: 1920 x 1080 x 4294967296 colors
	Used bit depth: 32
	Driver version: 10.18.15.4256
	Installed display drivers: igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igd12umd64.dll,igdumdim32,igd10iumd32,igd10iumd32,igd12umd32
	Current user language: English (United Kingdom)

12:11:21 [INF][    WQE backend]: Found auto-save workspace C:\Users\Lee\AppData\Roaming\MySQL\Workbench\sql_workspaces\-1.autosave
12:11:21 [INF][    WQE backend]: Found auto-save workspace C:\Users\Lee\AppData\Roaming\MySQL\Workbench\sql_workspaces\Cool-1.autosave
12:11:22 [INF][      Workbench]: UI is up

How to repeat:
12:12:39 [INF][      Workbench]: Running the application
12:12:41 [INF][      SqlEditor]: Opened connection 'Cool' to MySQL Community Server (GPL) version 5.6.27-log
12:12:42 [ERR][      Workbench]: Parameter is not valid.
Exception = System.ArgumentException
Message = Parameter is not valid.
FullText = System.ArgumentException: Parameter is not valid.
   at System.Drawing.Bitmap..ctor(String filename, Boolean useIcm)
   at TriangleNodeControl..ctor()
   at MformsTree.AddColumn(TreeColumnType type, String name, Int32 initial_width, Boolean editable)
   at MySQL.Forms.ViewEventTarget.HandleMouseClick(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Bug Report ^^^^

On opening the application, after the log "UI is up", an error message appears saying "Error while loading image search_sidebar.png". Simply pressing close to this would seem to dismiss the error and all is fine, but no.

After that, the home page appears as normal, but trying to connect with one of the saved connections displays the "Opening connection" dialog for a brief moment, then displays "Parameter is not valid", and asks to report a bug.

After that, clicking it makes it look fine again, but clicking the connection again does nothing, and trying to close the program makes it crash completely and werfault.exe kicks in. 

===================== Ran out of description space ===================

I'm not sure what causes the problem in the first place, but if you can get it to not find the file, that might be okay. 

1. Open workbench

There, you should have the error and it breaks. 

Suggested fix:
Maybe if there is a problem loading an image, based on the bug report that it crashes at trying to draw an image, maybe just catch failed drawings and continue anyway with a quirky UI. Better than an unusable application meaning I have to find another way to look after my data.
[3 Nov 2015 12:22] Lee Butler
Just adding workbench tag
[3 Nov 2015 12:51] Miguel Solorzano
See last comment in bug: https://bugs.mysql.com/bug.php?id=75334. Thanks.
[4 Nov 2015 13:24] Marcin Marek
I've tested this on WIndows 10 and windows 8 with msi installer looks ok for me, could be that your installtion gets corrupted. Can you try to reinstall Workbench and test it again?
[4 Nov 2015 14:08] Lee Butler
Seems to work fine now. Not sure what happened originally. First run had an error that it couldn't restore my previous workspace, but after that it's fine.
[4 Nov 2015 20:27] Miguel Solorzano
According last comment.