Bug #78919 connectivity problem of mysql in windows service on sytem start in windows 2012
Submitted: 22 Oct 2015 8:55 Modified: 22 Oct 2015 12:05
Reporter: Kamran Shahid Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version: OS:Microsoft Windows (Windows 2012 R2)
Assigned to: CPU Architecture:Any
Tags: connector, MySQL

[22 Oct 2015 8:55] Kamran Shahid
Description:
 have windows service (using .net fraemwork 4.5) installed in windows 2012 R2 machine. I have mysql connector 6.9.7 and mysql 5.6.25

When my service is started i am getting following error.

Authentication to host 'xxx.xx.x.xx' for user 'yyyyy' using method 'mysql_native_password' failed with message: Reading from the stream has failed. ---> MySql.Data.MySqlClient.MySqlException (0x80004005): Reading from the stream has failed. ---> System.IO.EndOfStreamException: Attempted to read past the end of the stream.

or some time

Unable to connect to any of the specified MySQL hosts.

If i restart the service in a while all seems to work properly Any idea what's the problem

How to repeat:
Install a windows service which connect ot mysql in windows 2012 r2
[22 Oct 2015 9:40] Chiranjeevi Battula
Hello Kamran Shahid,

Thank you for the bug report.
This is most likely duplicate of Bug #75917, please see Bug #75917

Thanks,
Chiranjeevi.
[22 Oct 2015 12:04] Kamran Shahid
more detail i found out is 
What after further investigation we have found that our database version was 5.6.25 . We have tried same connectivity with our old db 5.5.16 and we didn't face the issue. so looks like issue is database itself. our new database is installed in linux machine
[22 Oct 2015 12:05] Kamran Shahid
Moreover we are just circling in duplicate bugs but neither of the bug has solution.