Bug #78833 Attempt to open any configured connection results in crash
Submitted: 14 Oct 2015 17:41 Modified: 14 Oct 2015 18:30
Reporter: a g Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3 CE OS:Microsoft Windows (Windows 10)
Assigned to: CPU Architecture:Any
Tags: UI

[14 Oct 2015 17:41] a g
Description:
Upon opening MySQL Workbench and clicking any of the configured connections, an unexpected error pops up; The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception.

The software was working previously without error, which is why I already have configured connections. The log file contents are as follows;

10:32:52 [ERR][      Workbench]: Console redirection failed.
10:32:52 [INF][      WBContext]: Parsing application arguments.
10:32:52 [INF][      WBContext]:     C:\Program Files\MySQL\MySQL Workbench 6.3 CE\MySQLWorkbench.exe
10:32:52 [INF][      Workbench]: Starting up Workbench
10:32:52 [INF][      Workbench]: Current environment:
	Command line: "C:\Program Files\MySQL\MySQL Workbench 6.3 CE\MySQLWorkbench.exe" 
	CurrentDirectory: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	HasShutdownStarted: False
	OSVersion: Microsoft Windows NT 6.2.9200.0
	SystemDirectory: C:\WINDOWS\system32
	TickCount: 655811843
	UserInteractive: True
	Version: 4.0.30319.42000
	WorkingSet: 32272384
10:32:52 [INF][      Workbench]: Environment variables:
	COMPUTERNAME = HP-WORKSTATION
	USERPROFILE = C:\Users\setup
	HOMEPATH = \Users\setup
	LOCALAPPDATA = C:\Users\setup\AppData\Local
	ProgramFiles(x86) = C:\Program Files (x86)
	PSModulePath = C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\
	PROCESSOR_ARCHITECTURE = AMD64
	Path = C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Skype\Phone\
	CommonProgramFiles(x86) = C:\Program Files (x86)\Common Files
	Platform = HPD
	PROCESSOR_LEVEL = 6
	LOGONSERVER = \\MicrosoftAccount
	PATHEXT = .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
	HOMEDRIVE = C:
	VBOX_MSI_INSTALL_PATH = C:\Program Files\Oracle\VirtualBox\
	SystemRoot = C:\WINDOWS
	USERNAME = setup
	PROCESSOR_IDENTIFIER = Intel64 Family 6 Model 26 Stepping 5, GenuineIntel
	ProgramFiles = C:\Program Files
	SESSIONNAME = Console
	ALLUSERSPROFILE = C:\ProgramData
	PUBLIC = C:\Users\Public
	FP_NO_HOST_CHECK = NO
	APPDATA = C:\Users\setup\AppData\Roaming
	PROCESSOR_REVISION = 1a05
	OnlineServices = Online Services
	CommonProgramW6432 = C:\Program Files\Common Files
	TEMP = C:\Users\setup\AppData\Local\Temp
	CommonProgramFiles = C:\Program Files\Common Files
	OS = Windows_NT
	USERDOMAIN_ROAMINGPROFILE = HP-WORKSTATION
	FPS_BROWSER_APP_PROFILE_STRING = Internet Explorer
	ComSpec = C:\WINDOWS\system32\cmd.exe
	SystemDrive = C:
	FPS_BROWSER_USER_PROFILE_STRING = Default
	PCBRAND = Pavilion
	NUMBER_OF_PROCESSORS = 8
	TMP = C:\Users\setup\AppData\Local\Temp
	ProgramData = C:\ProgramData
	ProgramW6432 = C:\Program Files
	windir = C:\WINDOWS
	USERDOMAIN = HP-WORKSTATION
10:32:53 [INF][      Workbench]: Current version given by meta info is: 6.3.4
10:32:53 [INF][      Workbench]: Setting PATH to: C:\WINDOWS\system32;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Skype\Phone\
10:32:53 [INF][ mforms managed]: Initializing mforms wrapper
10:32:53 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	plugin path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	struct path: 
	module path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE/modules
	library path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	user data dir: C:\Users\setup\AppData\Roaming\MySQL\Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
10:32:53 [INF][      WBContext]: WbContext::init
10:32:53 [INF][            grt]: Scanning module directory C:\Users\setup\AppData\Roaming\MySQL\Workbench\modules.	
10:32:53 [INF][            grt]: Scanning module directory ..	
10:32:53 [INF][            grt]: Scanning module directory C:\Program Files\MySQL\MySQL Workbench 6.3 CE/modules.	
10:32:53 [INF][            WBA]: Looking for extension modules for WBA...
10:32:53 [INF][            WBA]: 0 extension modules found
10:32:53 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
10:32:53 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
10:32:53 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
10:32:53 [INF][            grt]: Scanning module directory C:\Program Files\MySQL\MySQL Workbench 6.3 CE.	
10:32:53 [WRN][            grt]: C:\Users\setup\AppData\Roaming\MySQL\Workbench\connections.xml:26: link '{2B854334-1981-4802-9BB4-979293C12723}' <object GrtObject> key=owner could not be resolved
10:32:53 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 6.3.4  revision 0 build 828 (64 bit)
	Configuration Directory: C:\Users\setup\AppData\Roaming\MySQL\Workbench
	Data Directory: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	Cairo Version: 1.10.2
	OS: Microsoft Windows 10 Pro
	CPU: 8x Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz, 9.0 GiB RAM
	Active video adapter NVIDIA GeForce GT 430
	Installed video RAM: -2048 MB
	Current video mode: 1920 x 1080 x 4294967296 colors
	Used bit depth: 32
	Driver version: 10.18.13.5362
	Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
	Current user language: English (United States)

10:32:53 [INF][      Workbench]: UI is up
10:32:54 [INF][      Workbench]: Running the application
10:32:55 [INF][      SqlEditor]: Opened connection 'ws2' to Source distribution version 5.0.95
10:32:55 [ERR][      Workbench]: The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception.
Exception = System.TypeInitializationException
Message = The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception.
FullText = System.TypeInitializationException: The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception. ---> System.ArgumentException: An item with the same key has already been added.
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at HtmlRenderer.Utils.FontsUtils..cctor()
   --- End of inner exception stack trace ---
   at HtmlRenderer.Utils.FontsUtils.IsFontExists(String family)
   at HtmlRenderer.Parse.CssParser.ParseFontFamilyProperty(String propValue)
   at HtmlRenderer.Parse.CssParser.AddProperty(String propName, String propValue, Dictionary`2 properties)
   at HtmlRenderer.Parse.CssParser.ParseCssBlockProperties(String blockSource)
   at HtmlRenderer.Parse.CssParser.ParseCssBlockImp(String className, String blockSource)
   at HtmlRenderer.Parse.CssParser.FeedStyleBlock(CssData cssData, String block, String media)
   at HtmlRenderer.Parse.CssParser.ParseStyleBlocks(CssData cssData, String stylesheet)
   at HtmlRenderer.Parse.CssParser.ParseStyleSheet(CssData cssData, String stylesheet)
   at HtmlRenderer.Utils.CssUtils.get_DefaultCssData()
   at HtmlRenderer.HtmlContainer.SetHtml(String htmlSource, CssData baseCssData)
   at HtmlRenderer.HtmlPanel.set_Text(String value)
   at MySQL.Forms.ViewEventTarget.HandleMouseClick(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
1) open MySQL Workbench

2) click a configured connection
[14 Oct 2015 18:30] Umesh Shastry
Hello!

Thank you for the bug report.
This is duplicate of Bug #75344, please see Bug #75344

Thanks,
Umesh