Bug #78683 Can't edit any stored procedure with Workbench
Submitted: 2 Oct 2015 14:41 Modified: 7 Dec 2015 20:59
Reporter: Adrian Murariu Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.4 OS:Microsoft Windows (Microsoft Windows 7 Enterprise Service Pack 1)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[2 Oct 2015 14:41] Adrian Murariu
Description:
Hello,
when I try to edit any stored procedure using alter procedure action with MySQL Workbench I allways get the error window that contain "the object's ddl statement contains syntax errors" message.

Even if I only open the procedure, without any change on it and try to save it, I get same error.

[      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 6.3.4  revision 0 build 828 (64 bit)
	Configuration Directory: C:\Users\adrian.murariu\AppData\Roaming\MySQL\Workbench
	Data Directory: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	Cairo Version: 1.10.2
	OS: Microsoft Windows 7 Enterprise Service Pack 1
	CPU: 2x Intel(R) Celeron(R) CPU        E3400  @ 2.60GHz, 3.9 GiB RAM
	Active video adapter Mirage Driver
	Installed video RAM: 0 MB
	Current video mode: 1920 x 1080 x 4294967296 colors
	Used bit depth: 32
	Driver version: 2.0.105.0
	Installed display drivers: NULL
	Current user language: English (United States)

How to repeat:
Open any stored procedure with alter procedure
click Apply button -> error window

OR

insert a comment line and click Apply button -> error window
[2 Oct 2015 14:51] Miguel Solorzano
That happens with modeling or alive connection?. Thanks.
[3 Oct 2015 13:15] Adrian Murariu
It happens with alive connection. Never tested with modeling.
I am wondering if is not related to size of stored procedure, which is 925 lines long.

I have attached the error message.
[3 Oct 2015 13:16] Adrian Murariu
error message on GUI

Attachment: error.jpg (image/jpeg, text), 39.89 KiB.

[4 Oct 2015 6:50] Umesh Shastry
Thank you for the feedback.
Tried with >1000 lines stored procedure without any issue, so there could be some other issue. Could you please provide problem-ed stored procedure to  confirm the issue at our end? You may want to mark it as private after uploading here.

Also, see if this is related Bug #77197
[4 Oct 2015 14:56] Adrian Murariu
Hello,
it sounds somehow similar with bug report you referenced, but with a small difference.
When I only open then try to save procedure there is no SYNTAX_ERROR mark in Name field, just error message window popup.

But if I add a comment line, no matter where, and try to save the procedure, then Name field change from procedure name to SYNTAX_ERROR and same error message window popup. Reading bug report you indicated and looking to my procedure, I have noticed now that following instruction is marked as syntax error.

truncate sd.4g_data_web_d;

To me, it looks good, as sd is the name of DB schema and 4g_data_web_d is table name.
[4 Oct 2015 16:39] Umesh Shastry
Thank you for the feedback.
[4 Oct 2015 16:40] Umesh Shastry
how to repeat steps

Attachment: 78683.results (application/octet-stream, text), 102.85 KiB.

[5 Oct 2015 11:15] Adrian Murariu
Hello Umesh,

are you asking me to try to update procedure using CLI? I don't understand your latest post.
[5 Oct 2015 11:18] Umesh Shastry
Hello Adrian,

No action is needed from your end.
I have included it as part of verification process.

Thanks,
Umesh
[7 Dec 2015 20:59] Philip Olson
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 6.3.6 release, and here's the changelog entry:

Attempting to add comments to stored procedures would fail with invalid
syntax errors.

Thank you for the bug report.