Bug #78633 HtmlRenderer.Utils.FontsUtils' threw an exception.
Submitted: 29 Sep 2015 22:51 Modified: 2 Oct 2015 3:23
Reporter: Thomas Knoblauch Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:MySQL Workbench 6.3 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[29 Sep 2015 22:51] Thomas Knoblauch
Description:
Installed new release of Workbench on Windows 10. Received the following message in log file and can't connect to a running MySql db:

Command line: "C:\Program Files\MySQL\MySQL Workbench 6.3  CE\MySQLWorkbench.exe" 
	CurrentDirectory: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	HasShutdownStarted: False
	OSVersion: Microsoft Windows NT 6.2.9200.0
	SystemDirectory: C:\WINDOWS\system32
base dir: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	plugin path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	struct path: 
	module path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE/modules
	library path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	user data dir: C:\Users\Admin\AppData\Roaming\MySQL\Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
17:43:56 [INF][      WBContext]: WbContext::init
17:43:56 [INF][            grt]: Scanning module directory C:\Users\Admin\AppData\Roaming\MySQL\Workbench\modules.	
17:43:56 [INF][            grt]: Scanning module directory ..	
17:43:56 [INF][            grt]: Scanning module directory C:\Program Files\MySQL\MySQL Workbench 6.3 CE/modules.	
17:43:57 [INF][            WBA]: Looking for extension modules for WBA...
17:43:57 [INF][            WBA]: 0 extension modules found
17:43:57 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
17:43:57 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
17:43:57 [WRN][            grt]: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
17:43:57 [INF][            grt]: Scanning module directory C:\Program Files\MySQL\MySQL Workbench 6.3 CE.	
17:43:57 [WRN][            grt]: C:\Users\Admin\AppData\Roaming\MySQL\Workbench\connections.xml:27: link '{E4BB051D-FBAB-4EF4-893A-2EBC467AD628}' <object GrtObject> key=owner could not be resolved
17:43:57 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 6.3.4  revision 0 build 828 (64 bit)
	Configuration Directory: C:\Users\Admin\AppData\Roaming\MySQL\Workbench
	Data Directory: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	Cairo Version: 1.10.2
	OS: Microsoft Windows 10 Pro
	CPU: 4x Intel(R) Core(TM) i3 CPU       M 330  @ 2.13GHz, 3.8 GiB RAM
	Active video adapter Intel(R) HD Graphics
	Installed video RAM: 1722 MB
	Current video mode: 1366 x 768 x 4294967296 colors
	Used bit depth: 32
	Driver version: 8.15.10.2900
	Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
	Current user language: English (United States)

17:43:57 [INF][      Workbench]: UI is up
17:43:57 [INF][      Workbench]: Running the application
17:44:55 [INF][      SqlEditor]: Opened connection '' to MySQL Community Server (GPL) version 5.6.21-log
17:44:56 [ERR][      Workbench]: The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception.
Exception = System.TypeInitializationException
Message = The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception.
FullText = System.TypeInitializationException: The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception. ---> System.ArgumentException: An item with the same key has already been added.
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at HtmlRenderer.Utils.FontsUtils..cctor()
   --- End of inner exception stack trace ---
   at HtmlRenderer.Utils.FontsUtils.IsFontExists(String family)
   at HtmlRenderer.Parse.CssParser.ParseFontFamilyProperty(String propValue)
   at HtmlRenderer.Parse.CssParser.AddProperty(String propName, String propValue, Dictionary`2 properties)
   at HtmlRenderer.Parse.CssParser.ParseCssBlockProperties(String blockSource)
   at HtmlRenderer.Parse.CssParser.ParseCssBlockImp(String className, String blockSource)
   at HtmlRenderer.Parse.CssParser.FeedStyleBlock(CssData cssData, String block, String media)
   at HtmlRenderer.Parse.CssParser.ParseStyleBlocks(CssData cssData, String stylesheet)
   at HtmlRenderer.Parse.CssParser.ParseStyleSheet(CssData cssData, String stylesheet)
   at HtmlRenderer.Utils.CssUtils.get_DefaultCssData()
   at HtmlRenderer.HtmlContainer.SetHtml(String htmlSource, CssData baseCssData)
   at HtmlRenderer.HtmlPanel.set_Text(String value)
   at mforms.MenuItem.callback(MenuItem* )
   at MenuItemEventTarget.MenuItemClick(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
I can repeat this consistantly on the Windows 10 machine. I can access the DB from another system that was not upgraded to Windows 10 using the same release of Workbench.
[29 Sep 2015 22:57] Miguel Solorzano
Thank you for the report.
This is duplicate of Bug #75344, please see Bug #75344