Bug #78540 MySQL Workbench fails to connect to database
Submitted: 24 Sep 2015 12:43 Modified: 24 Sep 2015 15:29
Reporter: Ken Peck Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any
Tags: HtmlRenderer, TypeInitializationException

[24 Sep 2015 12:43] Ken Peck
Description:
After upgrading from Windows 8.1 to Windows 10, connecting to a preexisting connection in MySQL Workbench generates an error stating that, "The type initializer 'HtmlRenderer.Utils.FontsUtils' threw an exception."  MySQL Workbench then stops working and closes.

Last entry from the log is:
08:27:54 [ERR][      Workbench]: The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception.
Exception = System.TypeInitializationException
Message = The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception.
FullText = System.TypeInitializationException: The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception. ---> System.ArgumentException: An item with the same key has already been added.
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at HtmlRenderer.Utils.FontsUtils..cctor()
   --- End of inner exception stack trace ---
   at HtmlRenderer.Utils.FontsUtils.IsFontExists(String family)
   at HtmlRenderer.Parse.CssParser.ParseFontFamilyProperty(String propValue)
   at HtmlRenderer.Parse.CssParser.AddProperty(String propName, String propValue, Dictionary`2 properties)
   at HtmlRenderer.Parse.CssParser.ParseCssBlockProperties(String blockSource)
   at HtmlRenderer.Parse.CssParser.ParseCssBlockImp(String className, String blockSource)
   at HtmlRenderer.Parse.CssParser.FeedStyleBlock(CssData cssData, String block, String media)
   at HtmlRenderer.Parse.CssParser.ParseStyleBlocks(CssData cssData, String stylesheet)
   at HtmlRenderer.Parse.CssParser.ParseStyleSheet(CssData cssData, String stylesheet)
   at HtmlRenderer.Utils.CssUtils.get_DefaultCssData()
   at HtmlRenderer.HtmlContainer.SetHtml(String htmlSource, CssData baseCssData)
   at HtmlRenderer.HtmlPanel.set_Text(String value)
   at MySQL.Forms.ViewEventTarget.HandleMouseClick(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)

How to repeat:
Clicking on an existing connection.
[24 Sep 2015 15:29] Miguel Solorzano
Thank you for the report.
This is duplicate of Bug #75344, please see Bug #75344