Bug #78444 taskeng.exe falsely reports a required upgrade is available for Installer
Submitted: 15 Sep 2015 13:54 Modified: 16 Sep 2015 5:51
Reporter: David Kubel Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:5.6.26.0 OS:Windows (7 x64)
Assigned to: CPU Architecture:Any
Tags: msiexec

[15 Sep 2015 13:54] David Kubel
Description:
Looking at the http://dev.mysql.com/downloads/windows/installer/ site, the version of MySQL Installer (5.6.26.0) has not changed since I last downloaded and installed it.  Why then does the daily scheduled program taskeng.exe always report “There is a required upgrade available for MySQL Installer.  To receive product catalog updates you must apply this upgrade.” ??

I am running 64-bit Windows 7 Pro SP1 and I do have an embedded space within my %USERPROFILE% environment variable, which I understand from another bug (#77965) may be one reason why when selecting “Yes” at this prompt, MySQL Installer then fails to install that required upgrade:

    Your product catalog was last updated at 22/06/2015 09:44:35

    Connected to remote catalog host
    Catalog download completed successfully
    Manifest not applied. Requires upgrade available and we are not running in interactive mode.
    Update done

    Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object.
        at WexInstallerConsole.Actions.UpdateAction.DoAction()
        at WexInstallerConsole.Program.Main(String[] args)

The OS then reports that MySQLInstallerConsole has stopped working and in another window, with the title “Windows Installer”, I see an error message (akin to a short response from msiexec --help) that suggests some incorrect command line parameters/values were presented when attempting to launch msiexec.exe.

I wonder though if the root cause for the failure to install the update is also related to the taskeng.exe program falsely reporting that a required update is available when one is not.  If not, is this a new defect?

How to repeat:
Wait till midnight for the next scheduled execution of taskeng.exe
[16 Sep 2015 5:51] Chiranjeevi Battula
Hello David Kubel,

Thank you for the bug report.
This is most likely duplicate of Bug #78138, please see Bug #78138

Thanks,
Chiranjeevi.
[16 Feb 2016 11:08] Anish Thomas
Getting the same error. is there a fix released for this ?