Bug #78324 a variable name have_statement_timeout should be change
Submitted: 4 Sep 2015 10:32
Reporter: Toshikuni Fukaya Email Updates:
Status: Open Impact on me:
Category:MySQL Server Severity:S4 (Feature request)
Version:5.7.8 OS:Any
Assigned to: CPU Architecture:Any

[4 Sep 2015 10:32] Toshikuni Fukaya
In MySQL server 5.7.8rc, The max_statement_time system variable was renamed to max_execution_time.
But the have_statement_timeout was not renamed, variable names are inconsistent.

How to repeat:
mysql> show variables like 'have_statement_timeout';
| Variable_name          | Value |
| have_statement_timeout | YES   |
1 row in set, 1 warning (0.00 sec)

Suggested fix:
Rename have_statement_timeout to have_execution_time.