Bug #7832 Query Browser 1.1.4, 1.1.5 won't start. Eat memory.
Submitted: 12 Jan 2005 10:49 Modified: 8 Jun 2005 15:45
Reporter: Maxim Vasyutin Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.4, 1.1.5 OS:Windows (Windows 2000)
Assigned to: Bugs System CPU Architecture:Any

[12 Jan 2005 10:49] Maxim Vasyutin
Query Browser 1.1.4, 1.1.5 won't stay running at all, with no messages displaying, no splash window, with no questions.... It simply devour very fast system memory and slow the system....So I have to use phpMyAdmin.... :(

How to repeat:

Suggested fix:
No fixes...
[12 Jan 2005 13:03] MySQL Verification Team
How fast does Query Browser eat system memory?
Are you working with Query Browser at that moment or it's idle?
Could you described it more detailed?
[12 Jan 2005 13:23] Maxim Vasyutin
I do not know what to say more....
I have DB named Db1 what has several little tables:

   dir                7   MyISAM    cp1251_general_ci      2.1 KB      -   
   folders                4   MyISAM    cp1251_general_ci      2.1 KB      -   
   goods                3   MyISAM    cp1251_general_ci      2.2 KB      -   
   images                3   MyISAM    cp1251_general_ci      2.1 KB      -   
   messages                7   InnoDB    cp1251_general_ci      16.0 KB      -   
   options                1   InnoDB    cp1251_general_ci      16.0 KB      -   
   orders                1   InnoDB    cp1251_general_ci      16.0 KB      -   
   orders_goods                1   InnoDB    cp1251_general_ci      16.0 KB      -   
   tmp_orders                0   HEAP    cp1251_general_ci      0 Bytes      -   
   us_dirs                13   MyISAM    cp1251_general_ci      2.3 KB      -   
   us_folders                5   MyISAM    cp1251_general_ci      2.1 KB      -   
   us_msg_dirs                16   MyISAM    cp1251_general_ci      2.3 KB      -   
   us_msg_folders                6   MyISAM    cp1251_general_ci      2.1 KB      -   
   users                4   InnoDB    cp1251_general_ci      48.0 KB      -   
  14 òàáëèö(û)   Âñåãî  71  --   cp1251_general_ci     129.3 KB    0 Bytes  
When I am trying to start MySQL QB - it cannot start at all. No messages. No windows are displaing. It starts fast eat memory. Until eat it fully, include virtual memory. 1 Gb In 20-30 seconds...

I tried to check, to repair, to optimize my tables, but... no results...
The bug started when I upgraded my QB 1.1.0 gamma to version 1.1.4.
[25 Jan 2005 20:22] Pat
I'm having the same problem.  When trying to start the program, my system will basically slow to a screeching halt with no evidence of the applicaiton running.  Upon checking the running processes, I find MySQLQueryBrowser.exe using nearly all of my available memory but very little processor time.  I tried experimenting with it by uninstalling & re-installing, uninstalling the Administrator and installing just this, re-starting the mysql service, etc.  Nothing seems to work.  PHPmyadmin and ODBC connections seem to work with no problems at all.  This machine is a testbed and I've removed pretty much all security / restrictions.

I'm running WinXP SP2
[26 Jan 2005 20:51] Jorge del Conde
While attempting to reproduce this bug, i realized mysqld crashed when QB tried to fetch the tables in the databases.

This could very well explain why you're seeing QB hang and consume a lot of memory.  Can you please check if your mysqld is running after QB starts to take a lot of time ?

I did this using mysql 5.0.2
[27 Jan 2005 1:49] Pat
Yeah, mysqld is still running after letting the Query Browser bog down my system for 5 minutes or so.
[30 Jan 2005 6:24] James DAVIS
I have this but but reported it as a new but  here http://bugs.mysql.com/bug.php?id=8192 (sorry)
[9 Feb 2005 13:17] Azam Sallie
I also had the same problem but when I logged to the machine from a different user login the query browser functions happily

So I created another account for me and exchange all my settings from the old user profile at Documents and Settings
[24 Feb 2005 13:07] Stefan Gudmundsson
When I had this problem I removed the files in the Do0cuments and Settings/<myprofile>/Application Data/MySQL and the Quey Broswer started fine. If you don't want to delete the files simply move them. Exactly what file or erason for the problem is still unknown though.
[9 Mar 2005 15:24] Sergio Jareño
I had the same problem but thanks to  Stefan Gudmundsson's comment I could solve this.

What I found in my C:\Documents and Settings\<MYPROFILE>\Application Data\MySQL folder was that "mysqlqb_options.xml" file had 2 GB size.

I just removed this single file and everything worked again.

[16 Mar 2005 15:28] James DAVIS
Thankyou Stefan Gudmundsson,
The file I had was 16 gigabytes. I just deleted it (Windows waste bin said it was too big for it) and reinstalled the browser which I had uninstalled and every thing now works fine. If it repeats again maybe we can produce some useful info for debugging.
Jim Davis
[7 Apr 2005 22:16] Michael Young
I just started to have this same problem myself.  I read the comments here and looked under the directory mentioned above.  I found that mysqlqb_bookmark.xml was about 14 mb.  I had to turn off the Mysql System Tray Monitor in order to delete it.  Once it was deleted, I started up Mysql Query Browser with no problems and I am back to normal.
[12 Apr 2005 13:00] John Bell
Thank you, thank you, thank you!!! That problem started with me last night, as usual at a critical time on a development project, and I spent way too many hours today uninstalling, reinstalling, rebooting, disabling this, reanabling that, and just before I was about to launch the computer through the nearest window  I stumbled on this and voila!:

Deleting the file mentioned in the user profile did the trick, thanks again guys!!!

Next time I'm gonna START by doing a search on Google ;-) (how many times have I said that...lol!)

[8 Jun 2005 15:45] Vladimir Kolesnikov
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Additional info:

For now QB will not read configuration files if they're of very large size. But to find out how those invalid (?) files are created I need an instance. Can anybody send example of such file? Thanks.
[10 Jul 2005 4:23] Kevin Conroy
I've encountered the same bug and I have a copy of my bad configuration file (It's just over 2.2GB!). I'll try attaching a zipped version of it to this comment. Is there another place I should send/upload it to? Any MySQL devs want me to send them a direct copy?