Bug #78232 unhandled error when exporting
Submitted: 26 Aug 2015 17:41 Modified: 5 Feb 2018 9:01
Reporter: Quijote Shin Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S4 (Feature request)
Version:6.3.4 OS:Linux (Ubuntu 15.04)
Assigned to: CPU Architecture:Any
Tags: exception, export, unhandled, WBBugReporter

[26 Aug 2015 17:41] Quijote Shin
Description:
My ~/.mysql/workbench/log/wb.log

14:25:42 [WRN][  TableEditorBE]: TIMESTAMP() is not a valid column typeUnhandled exception in toolbar callback for record_export: basic_string::substr: __pos (which is 1) > this->size() (which is 0)
14:27:49 [ERR][         mforms]: Unhandled exception in toolbar callback for record_export: basic_string::substr: __pos (which is 1) > this->size() (which is 0)
14:27:55 [ERR][         mforms]: Unhandled exception in toolbar callback for record_export: basic_string::substr: __pos (which is 1) > this->size() (which is 0)
14:27:58 [ERR][         mforms]: Unhandled exception in toolbar callback for record_export: basic_string::substr: __pos (which is 1) > this->size() (which is 0)

How to repeat:

1 ) set a column as TIMESTAMP() not TIMESTAMP,
2 ) set same column as TIMESTAMP
3 ) go to INSERTS tab
4 ) fill 1 line , with at least 1 field with "ñandú"
5 ) Click on export , save
6 ) Click on export again

I think the problem is "ñandú" bu even if I clean all or refill, will throw the same  exception:

"Unhandled exeption"
basic_string::substr: __pos (which is 1) > this->size() (which is 0)

Thanks,
Qshin
[5 Feb 2018 9:01] Umesh Shastry
Hello Quijote Shin,

Thank you for the feedback.
I was trying to reproduce the reported issue on Ubuntu 17.10 with WB 6.3.10 but not seeing any problems. Could you please confirm if you are still seeing this issue with 6.3.10? Thank you!

Thanks,
Umesh