Bug #78218 The database engine restarts due to internal failure. Got error: 2013: Lost con.
Submitted: 26 Aug 2015 8:27 Modified: 24 Apr 20:16
Reporter: Allan Andersen Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.5.43 OS:CentOS (32bit)
Assigned to: CPU Architecture:Any

[26 Aug 2015 8:27] Allan Andersen
Description:
mysqlcheck --database confluence
Warning: Using unique option prefix database instead of databases is deprecated and will be removed in a future release. Please use the full name instead.
confluence.AO_187CCC_SIDEBAR_LINK                  OK
confluence.AO_21D670_WHITELIST_RULES               OK
confluence.AO_26DB7F_ENTITIES_TO_ROOMS             OK
confluence.AO_26DB7F_ENTITIES_TO_ROOM_CFG          OK
confluence.AO_38321B_CUSTOM_CONTENT_LINK           OK
confluence.AO_42E351_HEALTH_CHECK_ENTITY           OK
confluence.AO_54C900_CONTENT_BLUEPRINT_AO          OK
confluence.AO_54C900_C_TEMPLATE_REF                OK
confluence.AO_54C900_SPACE_BLUEPRINT_AO            OK
confluence.AO_5F3884_FEATURE_DISCOVERY             OK
confluence.AO_5FB9D7_AOHIP_CHAT_LINK               OK
confluence.AO_5FB9D7_AOHIP_CHAT_USER               OK
confluence.AO_6384AB_DISCOVERED                    OK
mysqlcheck: Got error: 2013: Lost connection to MySQL server during query when executing 'CHECK TABLE ... '

From mysql log:
150826  9:58:28 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
150826  9:58:28 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
150826  9:58:28 [Note] Server socket created on IP: '0.0.0.0'.
150826  9:58:28 [Note] Event Scheduler: Loaded 0 events
150826  9:58:28 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.5.43'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MySQL Community Server (GPL)
150826 10:07:53 [Warning] IP address '192.168.100.191' could not be resolved: Name or service not known
08:18:38 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=8388608
read_buffer_size=131072
max_used_connections=38
max_threads=150
thread_count=38
connection_count=38
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 335704 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x9394820
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = ffffffffa3e3b31c thread_stack 0x30000
/usr/sbin/mysqld(my_print_stacktrace+0x34)[0x8401cf4]
/usr/sbin/mysqld(handle_fatal_signal+0x48c)[0x82c72ac]
[0x400400]
/usr/sbin/mysqld[0x84fa232]
/usr/sbin/mysqld[0x84a6ec7]
/usr/sbin/mysqld[0x84820f2]
/usr/sbin/mysqld[0x8482d96]
/usr/sbin/mysqld(_ZN7handler7ha_openEP5TABLEPKcii+0x44)[0x82ca074]
/usr/sbin/mysqld(_Z21open_table_from_shareP3THDP11TABLE_SHAREPKcjjjP5TABLEb+0x5fd)[0x823887d]
/usr/sbin/mysqld(_Z10open_tableP3THDP10TABLE_LISTP11st_mem_rootP18Open_table_context+0xef9)[0x817a9d9]
/usr/sbin/mysqld(_Z11open_tablesP3THDPP10TABLE_LISTPjjP19Prelocking_strategy+0x45a)[0x817b8ca]
/usr/sbin/mysqld(_Z20open_and_lock_tablesP3THDP10TABLE_LISTbjP19Prelocking_strategy+0x5b)[0x817c3bb]
/usr/sbin/mysqld[0x826ca0b]
/usr/sbin/mysqld(_ZN21Check_table_statement7executeEP3THD+0xdb)[0x826e52b]
/usr/sbin/mysqld(_Z21mysql_execute_commandP3THD+0x1ccb)[0x81b2b4b]
/usr/sbin/mysqld(_Z11mysql_parseP3THDPcjP12Parser_state+0x1a1)[0x81b7db1]
/usr/sbin/mysqld(_Z16dispatch_command19enum_server_commandP3THDPcj+0x1ebf)[0x81ba55f]
/usr/sbin/mysqld(_Z10do_commandP3THD+0xd4)[0x81bb044]
/usr/sbin/mysqld(_Z24do_handle_one_connectionP3THD+0xe5)[0x825fa85]
/usr/sbin/mysqld(handle_one_connection+0x51)[0x825fba1]
/lib/libpthread.so.0(+0x6b39)[0xa0cb39]
/lib/libc.so.6(clone+0x5e)[0x278c2e]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (ffffffffb6c7ff10): is an invalid pointer
Connection ID (thread ID): 55
Status: NOT_KILLED

The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
150826 10:18:39 mysqld_safe Number of processes running now: 0
150826 10:18:39 mysqld_safe mysqld restarted
150826 10:18:39 [Note] /usr/sbin/mysqld (mysqld 5.5.43) starting as process 14087 ...
150826 10:18:39 [Note] Plugin 'FEDERATED' is disabled.
150826 10:18:39 InnoDB: The InnoDB memory heap is disabled
150826 10:18:39 InnoDB: Mutexes and rw_locks use GCC atomic builtins
150826 10:18:39 InnoDB: Compressed tables use zlib 1.2.3
150826 10:18:39 InnoDB: Using Linux native AIO
150826 10:18:39 InnoDB: Initializing buffer pool, size = 128.0M
150826 10:18:39 InnoDB: Completed initialization of buffer pool
150826 10:18:39 InnoDB: highest supported file format is Barracuda.
InnoDB: Log scan progressed past the checkpoint lsn 28128071961
150826 10:18:39  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 28128106575
150826 10:18:39  InnoDB: Starting an apply batch of log records to the database...
150826 10:18:40 InnoDB: 5.5.43 started; log sequence number 28128106575
150826 10:18:40 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
150826 10:18:40 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
150826 10:18:40 [Note] Server socket created on IP: '0.0.0.0'.
150826 10:18:40 [Note] Event Scheduler: Loaded 0 events
150826 10:18:40 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.5.43'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MySQL Community Server (GPL)

How to repeat:
I have been updating my confluence installation and tried to update a plugin which failed to write some data to the database. Now one table is corrupted and as you can see the mysqlcheck fails when running it.

I have tried to set the innodb recover paramter with no luck. Even if I try to fetch data from the table the database engine crash and restarts.
[24 Apr 20:16] Miguel Solorzano
Not repeatable test case was provided to check with most recent releases.