Bug #78193 MySQL installer community edition hangs
Submitted: 24 Aug 2015 18:04 Modified: 1 Sep 2016 2:45
Reporter: Shobana Sundaram Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.6.26 OS:Microsoft Windows (windows 7 Pro)
Assigned to: Jose Gabriel Valencia Ornelas CPU Architecture:Any

[24 Aug 2015 18:04] Shobana Sundaram
Description:
I am trying to install Mysql on my windows7 Pro machine for the first time, it startup and then hangs at the window indicating "gathering required Information", please wait while windows configures Mysql installer. This has happened multiple times, cancel button doesn't kill the process, I had to restart the computer.

Once in the beginning, it indicated some requirements such Visual studio and python connector need to be manually installed, I tried doing that. Now, when I start the installer, it gets nowhere, it is stuck. I can't make any sense out of it. I tried stopping firewall, it didn't help.

How to repeat:

just download the MySQL community installer on a windows 7 pro machine and try it.
[24 Aug 2015 22:08] Miguel Solorzano
Hanging

Attachment: installer_stuck.png (image/png, text), 444.21 KiB.

[24 Aug 2015 22:09] Miguel Solorzano
Thank you for the bug report.
[26 Aug 2015 22:36] Javier Treviño
Posted by developer:
 
Can't duplicate the issue.
Tried 5.6.26 Server bundles (both web and full bundles downloaded from dev.mysql.com) on a Win 7 professional and also a Win 8.1 professional environments.
In all tests the Installer took some time to run, during which one might think it is stuck, but after some minutes the installation completed successfully.

I am wondering how this bug could be verified.
[27 Aug 2015 5:50] Shobana Sundaram
Thank you for trying to reproduce it. On my machine, it was stuck for several hours. I have tried the both the web installer and the other msi. It is possible that it might be my system issue, when there is no feedback, I can't make any sense out of it. I don't know if there is any other way to install mysql, should I download the binary and try it.
[27 Aug 2015 14:25] Miguel Solorzano
To verify I removed all MySQL products using the Control Panel uninstall option on Windows 7 running on VirtualBox. The screenshot I attached keeps hanging but when press cancel the installer proceed installing several items.
[27 Aug 2015 16:47] Javier Treviño
Miguel,
That is the way I tested, on a clean environment with no MySQL products, I ran both the web and full 5.6.26 bundles on a VM with Win7 professional. The installation was completed successfully.

You said that in your test you clicked cancel and the installer proceeded to install several items. I do not understand since with the given steps there are no products being installed, so only the MySQL Installer should be installed on the computer.

What other items were installed on your test?
If other items were installed, does that mean you ran the Installer after it was successfully installed and attempted to install other MySQL products and then it hangs?
[27 Aug 2015 17:16] Shobana Sundaram
I have tried the cancel button as well, it never really cancelled and it hanged. I had to restart my computer to get rid off the processs. Neither the installation works, nor the cancel button, it just hangs for hours with no feedback! I have tried this multiple times.
[27 Aug 2015 17:19] Javier Treviño
Can you tell me exactly the name of the file that you are running?

Also it would be very helpful if you can run the following and attach the output log to this bug report:

msiexec /i <MSI_File> /l*v c:\MsiLogFile.txt

Just replace <MSI_File> with the actual filepath of the file you are running.

Thanks.
[27 Aug 2015 17:57] Miguel Solorzano
Products installed after hit cancel button

Attachment: products_installed.png (image/png, text), 96.17 KiB.

[27 Aug 2015 17:58] Miguel Solorzano
The package I used is mysql-installer-community-5.6.26.0.msi and now I will clean and try install again for double check.
[27 Aug 2015 18:02] Miguel Solorzano
The complete list from Control Panel uninstall products

Attachment: complete_list.png (image/png, text), 26.96 KiB.

[27 Aug 2015 18:03] Javier Treviño
Miguel,
Now that makes me think that the time where the Installer hangs for you is different to the one reported by Shobana.  You show that the Installer installed several MySQL products which means that you could actually run the MSI (so it installs the MySQL Installer), open it to select which products you want to Install and while installing those it failed?

My understanding from reading the steps to duplicate is that the mysql-installer-community-5.6.26.0.msi was hanging. Running that MSI will not install any MySQL product BUT the MySQL Installer.

Can you please clarify your steps to duplicate?
[27 Aug 2015 18:34] Miguel Solorzano
Unlucky now I am not able to repeat the hanging behavior anymore. The only difference I could say I had is when it was hanging I removed the stuff installed with 5.6.25 version and now I removed the 5.6.26 so not more useful feedback I can offer.
[27 Aug 2015 19:19] Javier Treviño
OK I will wait for any feedback from Shobana about getting a log to see if there is something we can do.  But we need to be able to duplicate this problem otherwise we will close the bug.
[28 Aug 2015 21:48] Shobana Sundaram
Log file for  MySql installer

Attachment: MsilogFile.txt (text/plain), 174.36 KiB.

[28 Aug 2015 21:52] Shobana Sundaram
Thanks for looking into this. I ran the script and I have attached the log file.  I tried running the installer for 20 mins or so, it was hanging, I tried cancel button, doesn't seem to have any effect. I had to restart my computer to get rid of the process.
[28 Aug 2015 21:54] Javier Treviño
Thanks Shobana, we will take a look to it.
Can you please tell us what MSI exactly did you run (its filename)?
[29 Aug 2015 1:12] Shobana Sundaram
The file is mysql-installer-community-5.6.26.0  (size 253 MB).
The log file is for this installer.

I have also tried the web version earlier, noticed a similar behavior.
[25 Sep 2015 23:32] Jose Gabriel Valencia Ornelas
Posted by developer:
 
Will be checked the path to execute the launcher, normalize and remove extra \ from the path
[25 Sep 2015 23:56] Jose Gabriel Valencia Ornelas
Posted by developer:
 
we couldn't reproduce the error that the user is having, the best shot we can do for now is validate the MySQL Launcher full path,  that is normalized and doesn't contain double slashes.

After release if it continues happening the issue, the bug needs to be re-open for further reviews
[11 Oct 2015 19:00] Mihai Ioachim
Same for me, mysql_5.7.27 hangs on install. First installation on Windows 10.

The zip one works, but I need all the utilities that came with the msi, so I'm back to zero.

What can I do? Thanks.
[11 Oct 2015 19:05] Mihai Ioachim
error

Attachment: 2015-10-11 15-07-20.png (image/png, text), 8.25 KiB.

[12 Oct 2015 22:52] Jose Gabriel Valencia Ornelas
Hi  Mihai Ioachim

your problem looks to be the same that is lot executing the MySQLInstallerLauncher, this is not continue at all even if pass some amount of time?

we already have an small fix to avoid and normalize the path and filename used in the installer but is not released yet, in the meantime you can use the following workaround

open and command prompt with admin rights
execute:
msiexec /i <full path with the MySQL Installer msi filename> /qn 

this will install the installer but not execute anything

look in your start menu for the MySQL folder -> MySQL Installer -Community/Commercial and execute from there
[10 Nov 2015 22:59] Philip Olson
Posted by developer:
 
Fixed as of the upcoming MySQL Installer 1.4.12 release, and here's the changelog entry:

The launcher path is now normalized, and extra slashes are removed from
the path.

Thank you for the bug report.
[28 Feb 2016 19:51] Paul Marcelo
MySQL Community Server 5.7.11

Attachment: MySQL Community Server 5.7.11 .jpg (image/jpeg, text), 17.45 KiB.

[28 Feb 2016 20:00] Paul Marcelo
Hi also had the same problem but with MySQL Community Server 5.7.11 and Windows 10 version 1511. By task manager remove the Windows Installer (32-bit) process. And then it was concluded the installation of MySQL Community.
[3 Apr 2016 23:28] Duncan Ogweno
Inability to install MySQL

Attachment: mysql-bug-data-78193-mysql201604040208.zip (application/zip, text), 20.99 KiB.

[4 Jun 2016 13:16] Deana Holmer
I am reproducing this problem on community web installer 5.7.13.0 on Windows 7.  I have performed uninstall, deleted files to the best of my ability.  It looks clean but the installer just hangs and cancelling has no effect. 

Open to suggestions..
[14 Jun 2016 20:03] Javier Rivera Zavala
Posted by developer:
 
By looking at the logs I suspect there's a conflict produced by restrictive machine policies. I've ran the same tests on my machine and couldn't find the following lines in my logs:

MSI (c) (5C:A0) [01:32:26:052]: Note: 1: 1402 2: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 3: 2 
MSI (c) (5C:A0) [01:32:26:053]: SOFTWARE RESTRICTION POLICY: Verifying package --> 'E:\Software\Devtools\DB\MySQL\mysql-installer-community-5.7.11.0.msi' against software restriction policy
MSI (c) (5C:A0) [01:32:26:079]: SOFTWARE RESTRICTION POLICY: E:\Software\Devtools\DB\MySQL\mysql-installer-community-5.7.11.0.msi has a digital signature
MSI (c) (5C:A0) [01:32:31:825]: SOFTWARE RESTRICTION POLICY: E:\Software\Devtools\DB\MySQL\mysql-installer-community-5.7.11.0.msi is permitted to run at the 'unrestricted' authorization level.
[19 May 2017 19:59] Franklin Alagala
This happens on a 64 bit Operating System. Just go to Task Manager and end Winsdows Installer for 32 bit. You are now good to go :)