Bug #7786 Um, German/French/Italian UTF-8 collations?
Submitted: 10 Jan 2005 23:34 Modified: 12 Jan 2005 18:55
Reporter: Ryan Schmidt Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.1.8 OS:N/A
Assigned to: CPU Architecture:Any

[10 Jan 2005 23:34] Ryan Schmidt
Description:
Hi. Sorry to bug you, and sorry if this has been discussed before. I couldn't find a relevant similar 
bug, and the documentation doesn't seem to address it.

Our company develops a CRM system used by a customer with locations across Europe. Along 
with the host of latin1 countries they've already launched, they now want to roll this product out 
to their latin2 locations, including Poland, the Check Republic and Slovakia. Thanks to MySQL 4.1, 
we can convert the database from latin1 to utf8 and should be able to handle this. Since a user in 
any country might conceivably see a list of names and addresses from multiple countries, using 
either latin1 or latin2 for the connection charset won't be sufficient, so we intend to use utf8 for 
that as well. We're confused however about how to handle sorting, since there don't appear to be 
any German, French or Italian collations for utf8. My boss and I spent some time today, figuring 
out where the existing utf8 collations are defined in the MySQL source, reading up on the Unicode 
collation algorithm, trying to divine how to specify the rules necessary to do German sorting, but 
after about an hour of this we were both pretty ready for a beer, and sure that we weren't the 
only ones scratching our heads, so we thought we should ask you: Why are there no German / 
Italian / French collations for utf8? Is it because one of the other existing utf8 collations would do 
the same thing? Or is it because nobody's gotten around to it yet? We searched Google to try to 
find others working on these collation definitions, but without success. Thanks for any help you 
can offer.

How to repeat:
N/A

Suggested fix:
N/A
[11 Jan 2005 15:33] Sinisa Milivojevic
This is a feature request, and we shall label it as one.

We simply did not find time to do it yet, but we shall be doing it.

If you would volunteer to add some of those, we would be truly gratefull.
[11 Jan 2005 19:42] Sergei Golubchik
you can use convert to latin2 collation in order by to get the sorting order you want
[5 May 2006 17:45] Lutz Schwarz
Could be the reason why there is no separate german collation for unicode:

http://bugs.mysql.com/bug.php?id=19567